How do I disable lock screen when wake from suspend?

How do I disable lock screen when wake from suspend?

Postby Chad » Mon Mar 20, 2017 3:05 pm

I installed Zorin OS on my laptop a few days ago and I'm liking it a lot. There is just one thing bugging me:

When I close the lid on my laptop, it sleeps, as expected. But when I open the lid, it displays a screen with the time, then I have to press a key to get a login screen, then I have to enter my password. I would like to disable this but can't figure out how. I previously used Elementary OS and one great thing about it was that you would have a working desktop within 1 second of opening the laptop from sleep. The funny thing is, Zorin actually shows a working desktop for about 1-2 seconds when you open the lid, then it disappears and shows the screen with the time.

So far I have tried the following and none of it worked:

-under "Power", set "dim screen when inactive" to off
-under "Power", set "blank screen" to never
-under "Power", set "automatic suspend" to off
-under "Privacy", set "screen lock" to off
-under "Users", set "automatic login" to on
-using dconf-editor, set org.gnome.desktop.lockdown.disable-lock-screen to on
-in /etc/default/acpi-support, comment out LOCK_SCREEN=true

Any help is appreciated.
User avatar
Chad
 
Posts: 5
Joined: Mon Mar 20, 2017 2:49 pm

Re: How do I disable lock screen when wake from suspend?

Postby Swarfendor437 » Mon Mar 20, 2017 10:24 pm

Hi, If you have not done so already, install gnome-tweak-tool via the ternminal (Menu | Utilities | Terminal or Ctrl+ Alt+ T):

Code: Select all
sudo apt install gnome-tweak-tool


This will add 'Tweak Tool' to Menu | System Tools.

Launch it, then select 'Extensions' from the left pane. Now if you have disabled screenlock, select 'Disable screen shield' and that should stop the annoying screen lock with date and time from appearing.

Disable screen shield.jpg
http://www.vimeo.com
trisquel.info
gnome-look.org

Machine: ASUS M5A78L-M/USB 3, AMD Phenom II x 6, 4 Gb RAM, nVidia Graphics GT620 (2 Gb)
User avatar
Swarfendor437
 
Posts: 7393
Joined: Wed Sep 18, 2013 5:51 pm

Re: How do I disable lock screen when wake from suspend?

Postby Chad » Tue Mar 21, 2017 1:44 am

Hmm when I click on Extensions in the tweak tool I see a completely different list of options than in your screenshot. "Disable screen shield" isn't there. I tried searching for it in the search box and it's not there. Any ideas?
Attachments
screenshot.jpg
User avatar
Chad
 
Posts: 5
Joined: Mon Mar 20, 2017 2:49 pm

Re: How do I disable lock screen when wake from suspend?

Postby Chad » Tue Mar 21, 2017 1:55 am

Ok I see you have to install that option as an extension: https://extensions.gnome.org/extension/ ... en-shield/

But it doesn't work, I installed the extension and set it to on, and I still get the lock screen when I wake from sleep. The screen lock is set to off under privacy.
User avatar
Chad
 
Posts: 5
Joined: Mon Mar 20, 2017 2:49 pm

Re: How do I disable lock screen when wake from suspend?

Postby Chad » Tue Mar 21, 2017 2:06 am

Aha! I figured it out.

In dconf-editor, find org.gnome.desktop.screensaver ubuntu-lock-on-suspend and uncheck it.

Now I close the lid and it sleeps, I open the lid and it's a working desktop immediately. Just what I wanted. I can't believe this option is so well hidden. Hopefully this helps someone.
User avatar
Chad
 
Posts: 5
Joined: Mon Mar 20, 2017 2:49 pm

Re: How do I disable lock screen when wake from suspend?

Postby Swarfendor437 » Tue Mar 21, 2017 1:26 pm

Hi Chad, Always helps if you get a Notebook (Laptop) user to figure things out as I don't run Zorin on a Notebook. Thanks for sharing - 120 blue jewels to you sir - 60 for solving the issue yourself and another 60 for sharing! ;) :D
http://www.vimeo.com
trisquel.info
gnome-look.org

Machine: ASUS M5A78L-M/USB 3, AMD Phenom II x 6, 4 Gb RAM, nVidia Graphics GT620 (2 Gb)
User avatar
Swarfendor437
 
Posts: 7393
Joined: Wed Sep 18, 2013 5:51 pm

Return to Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 8 guests