This is a static archive of the old Zorin Forum.

The information below may be outdated. Visit the new Zorin Forum here ›

If you have registered on the old forum, you will need to create an account on the new forum.

[SOLVED] Weird Installation


Tue Jun 26, 2012 10:30:12 pm

Hello, Everyone

Hi am new to forums and am telling you that i Love Zorin OS. I don't know why I didn't search for it sooner but this distro is the greatest when i saw a video on linux distros and saw this one and i thought wow this OS looks so cool that i went and download it and am happy!!

Anyways, on topic i just want to report on something its a really weird installation especially on my computer when i first install Zorin and didn't work. when i first downloaded and burn it to a DVD. i boot up my computer and it tells me the zorin menu. You know installing directly, boot to live mode etc.. so when i went to boot to live mode as soon as i hit enter it was showing a gray screen with a blinking cursor. I thought "hey lets give it a couple of minutes maybe its taking its time on the recognizing the hardware" and so on. After i came back to the computer after 10 minutes it was still in that gray screen with the blinking cursor. (Mind that i ran out a blank DVD's) i thought it was a bad download or bad DVD so i went again and downloaded another fresh copy and well this time i made it into a PENDRIVE. making it boot from a USB stick. but nope still it didn't work at all! Damn it :x But not so fast, (mind you that am still a noob at linux) so i started heavily searching around google trying to figure out why was it hanging at the grey screen with the blinking cursor but, then i figured what about if use nomodeset.

Here is the wierd part! :ugeek:

So after a million tries to get it working i figured well lets try this and see if this works so on the zorin menu on the bottom screen i saw the message something about pressing tab for more options. but when i look I choose the options for that specific selected action in the menu. so i selected "Install Directly" and press tab. so then i typed in "no nomodeset" and when i press enter i saw that it went through meaning it actually started the installation. i was like wow is this correct or am i doing the right thing here because this is weird or am just an idiot! :lol: so then the installation went through. I figured Yay! it worked when i login into the system i saw that the display was flickering a lot so damn what now! so i went to the additional drivers searching for my video card and selected the second driver for nvidia. and finally i restarted my PC and all i can say its amazing experience the problem was instantly solved.

My theory is that maybe the video card was causing the issue. But since i don't know much about how linux operates on hardware i didn't know if it was something on my computer or it was one of the hardware devices as it turned out it was the video card but like i said am still a noob. :lol:

So my question is? is this correct? did i do the right thing? i know the installation was a success and everything is working fine and dandy, but still want to know if this was the correct procedure to do? can some one shine the light on this because wow!! and by the way this is to help if someone has similar problems on it too. maybe this is the solution if people were getting the grey screen with the blinking cursor. and BTW, The Computer Specs:

Dell Vostro 260MT
Nvidia GTX 550 Ti Fermi
Intel Core I3 2120 3.3GHz

And thank you guys for reading this long freaking post!! :lol:


Wed Jun 27, 2012 5:51:27 am

First of all, well done for finding a solution to this problem.
If I recall correctly, in the boot menu there is an option saying :boot in low graphics mode. Have you tried this?

Nvidia seems to be having some problems with gnome 3 and bug reports have been filed. However, the best thing to do is to activate the recomended drivers, like you did. Since all seems to be working, relax and enjoy the OS. Like they say: if it's working, don't fix it. :D


Wed Jun 27, 2012 6:07:12 am

Hey, madvinegar

Thanks for the reply, hopefully if someone out has this problem they now have some sort of hope :lol: and your right "if ain't broke, don't fix it" Thanks for the reply too!! and glad to help on everyone's adventures. :D

oops, i forgot to mention

when i booted up i think there was the option of graphics mode i think i don't remember but yeah i tried that it was still with the grey screen with the blinking cursor it was the same.


Wed Jun 27, 2012 6:40:48 am

Hi and welcome,

make sure you update your system fully:


You might want to read the post install guide too!!:


Regards Wolfman :D


Wed Jun 27, 2012 7:00:41 am

Hey Wolfman,

Thanks for your reply, actually i got it fully working now as i mention in the first post, the only problem was that i couldn't access the live boot mode and the graphics mode it kept giving me the grey screen with the blinking cursor. so i just type the command from the tab options "no nomodeset" and the installation started and the system was installed directly. i did however, once finished the installation i did update the system fully, but everything else is working fine now.

Thanks for your topics as well i read them completely.


Sun Nov 18, 2012 3:12:28 pm

ChipMan66 wrote:I am having the same problem.Screen flicker after new install.


have you updated?, and do you have an Nvida card?.



Let us know if this helps.

Regards Wolfman :D


Thu May 23, 2019 2:12:11 pm

My pendrive is not showing in Zorin os