This is a static archive of the old Zorin Forum.

The information below may be outdated. Visit the new Zorin Forum here ›

If you have registered on the old forum, you will need to create an account on the new forum.

Graphics/Booting Issue after battery died


Sat Jun 11, 2011 12:47:57 am

I installed Zorin OS 4 64-bit on my Asus K72F laptop about a month ago, and it has worked seamlessly for me up until now:

This started after my computer's battery died while it was running.

When I try to boot, I get the splash screen (with the Z in the blue bubble and spacey background) then the screen goes blank (as it should), but the problem is, it stays blank rather than going to the login screen as it should. When I press and hold the power button to turn off the computer, I see the splash screen briefly again before the computer shuts down.

IMPORTANT: When I boot into recovery mode and choose FailSafeX, the computer then goes to the screen where it says the graphics card could not be detected properly, and gives me a list of options, one of which is to run Ubuntu in low-graphics mode for one session. I usually choose that and then I get the login windows as I should, I login and everything is working perfectly except, of course, the 3D graphics are gone (for example, CompizConfig is almost completely unnoticeable when I use Zorin in this mode).

When I run lspci in terminal, this is one line of the result:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

Judging by the other forums I have searched, I may have been running an update when my computer died, but I'm not sure. I have already tried dpkg from the recovery mode multiple times to no avail.


Wed Jun 15, 2011 4:07:32 am

What filesystem are you using? If ext2 or ext3 I would try booting from the DVD and running fsck on the hard drive to see if it can recover any damaged files if it shut down in middle of an update, or in middle of running without updating for that matter, file corruption can destroy the OS in a second by corrupting critical OS files that are in use at the time it went dead. Hope that may help you a bit...


Thu Jun 16, 2011 12:03:35 am

I am using an ext4 filesystem. Would running fsck have any possibiity of fixing this?

I tried running

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates 
sudo apt-get update
sudo apt-get upgrade

because I think the intel graphics driver has a problem, but I got this:
Depends: xorg-video-abi-7.0

and then a whole list of things that have been held back.

I tried installing xorg-video-abi-7.0 with aptitude, but I got this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package xorg-video-abi-7.0 is a virtual package provided by:
  xserver-xorg-core 2:1.8.2+git20100705+server-1.8-branch.665aa7ce-0ubuntu0sarvatt2~lucid [Not candidate version]

E: Package 'xorg-video-abi-7.0' has no installation candidate

My current version of xserver-xorg-core is 2:1.9.0-0ubuntu7.3


Thu Jun 16, 2011 1:22:11 am

This will help you to check and possibly repair a broken filesystem, the video drivers could be the issue however with it dying, checking the filesystem for corruption should be the first thing to do ... in-ubuntu/

May find no problems at all with the filesystem, that would be great, but then need to figure out what's the deal with that video driver, how far did it get installed etc, the easiest thing of course would just be backup your home directory and reload, but that can be a pain as well


Tue Jun 21, 2011 12:16:59 am

I just tried that to no avail.

At this point I am certain that the problem is that somehow, I have lost the xorg-video-abi-7.0 package.

Since Zorin is open-source, though, is there any way for me to download it and install it into my system?