This is a static archive of the old Zorin Forum.

The information below may be outdated. Visit the new Zorin Forum here ›

If you have registered on the old forum, you will need to create an account on the new forum.

swarfendor437's miscellania ...


Sat Oct 17, 2015 10:11:38 am

This thread will accumulate various 'tips and tricks' with ZorinOS with screenshots. For this reason, the thread will be locked for responses so please don't post here - ask elsewhere please! ;) :D

If any posts do show up they will get deleted! :D


Sat Oct 17, 2015 10:26:54 am

Well a bit of background, I decided not to dual-boot with Windows 7 any more and put Zorin on an older drive in my hot-bay - which was ear-marked for Win10 but forgot this is on an old 'fatter' drive so a recycled ExcelStor drive from the youngest's machine. Zorin 9 was not playing nice with Cairo-Dock so I am back using Zorin 10 which my video tutorial was used for in producing Zorin - Updates and tweaks video where I found that VLGothic font is much more suited to the terminal.
Back to business:

1. Removing packages you are not going to use (in this example it is Zorin 32-bit Ultimate) and in this instance this is down to my personal preferences, i.e., stuff I don't want on the machine which in turn will also reduce the amount of updates coming through so this might be worth doing BEFORE you start updating your system after first install.

So the best way to remove packages COMPLETELY is to use the 'purge' command in the Terminal (Ctrl+ Alt+ T or in Zorin 9 Menu | Accessories | Terminal or in Zorin 10 Menu | System Tools | Terminal)

Not sure what each program is named for 'Terminal' purposes? Well select the 'Z' Menu button, go to the Application Group e.g., Games, Office, select an application by right-clicking and select 'send to desktop.

Once there, right-click the shortcut on the desktop and select properties. In the screenshot I have selected 'homebank'. [I NEVER use internet banking - here in the UK the consumer body 'Which?' did a survey a couple of years ago and even the most secure banks only got an 81% security rating which speaks volumes in itself!)

Notice in the terminal you can select more than one application you no longer require - you just have to ensure that you add a space between each one - this also works in reverse if you know the name of the application you want to install - if 'apt' does not find it it may well provide you with a named suggestion - go with that if it finds one.

Here is the screenshot: [If there is no screenshot it is because I will be installing another browser other than Firefox that works!]

removing software via terminal.jpg

Well it has worked because I am using Zorin 10! I shall probably stick with this beyond end-of-life until Zorin 11 comes out, the next LTS I suspect! ;-)

[Note: homebank should have been 'HomeBank' - unusual to see capitals for apps in the Terminal! trigger should have been 'trigger-rally' and mines 'gnome-mines'! and it appears you cannot use a 'list of apps' as before! After you have used the 'purge' command you will also need to use:

sudo apt-get autoremove
to remove any associated files/folders, principally 'game data' in respect of games such as 'xonotic' etc. so if you get this prompt, do it! :D


Sat Oct 17, 2015 12:26:29 pm

In another post I pointed to an ubuntu site which stores both i386 (32-bit) and 64-bit AWN applets.

I had archived the originals I downloaded - some minor ones will not install because they are/were dependent upon Gnome 2 - most GNU/Linux distributions are now using Gnome 3, including Zorin. For the ones that are 'out-of-date' 'gdebi' will notify you of this. 'gdebi' is not present in the Zorin .iso's so you will need to add it after installation via a terminal:

sudo apt-get install gdebi

Then when installing .deb packages, right-click them and select 'open with ...' and choose 'gdebi'. gdebi is excellent at notifying you of any missing dependencies and/or whether a package will install or otherwise.

In the screenshot provided I show this (see window open top left - click on the 'close' button, then click on 'Download Package' - this will automatically download the package right next to the original one in your Downloads folder, then click on install to install the latest package:

[Uploads have stopped working - back to Opera 12.16!!!]


Fri Oct 30, 2015 10:47:52 am

Interesting article on search engines here: ... /74408908/


Sat Nov 14, 2015 7:29:40 pm

Interesting documntation on EFI (Secure boot) here:


Sat Nov 21, 2015 8:25:50 pm

Safely remove Zeitgeist spyware from Zorin Core/Ultimate: ... -zeitgeist

Open a terminal (Ctrl+ Alt+ T or Menu | Accessories | Terminal) and enter:

sudo apt-get remove zeitgeist zeitgeist-datahub zeitgeist-core

[Note: Wolfman has provided different method needed for users of Zorin Lite]


Sun Nov 22, 2015 12:09:09 am

Well installed Zorin 9 Ultimate (32-bit) once more tonight and decided to browse the Software Centre to see what was under the 'Installed' tab and removed the following to see if I could 'break' Zorin:

Items removed:


Activity Journal

Akonaditray with Kraft

Nepomuk Backup


Activities and Privacy Manager Tool

Deja Dup Backup Tool

Bluetooth Transfer


Left alone as not sure might have a knockon on other packages



Mines (gnome-mines)



Frets on Fire


Warzone 2100


Nothing removed


Thunderbird Email

Gobby Collaborative Editor (0.5)

KNetAttach (Personal accounting software - eqonomize, kdenlive, debug package manager for kubuntu, Batch package manager for kde)

Transmission BitTorrent



LibreOffice Base

wxBanker Finance Manager


Left alone - except for Kdenlive which went with KNetAttach!


Left alone


Left Alone


Gnome Flashback Services - Screensaver and locker addon removed

Reactivate HP Laserjet 1018/1020 after reloading paper


Unity 8

Evolution Data Server

The main problem that happened was loss of 'System Settings' in that only 4 or 5 items remained! I got System Settings back by having to reinstall 'Unity':




Sun Nov 22, 2015 1:12:47 pm

OK, so I installed Opera from the 'Zorin Web Browser Manager' customised the search engines and even after deleting 'Google' and other search engines it kept coming back. I decided to uninstall it and download the 'official' opera package from here:


Sun Nov 22, 2015 1:19:30 pm

Some issues with the above image not showing in submit window at all!

Here is the rest of the Opera post:

After download and install I was still getting Google as default - then I remembered, had to delete the 'hidden' '.opera' file in my '/home' folder. When you install the official Opera 12.16 from with gdebi you will get a message to say that it already exists in the software channel - (but we don't know how it has been tweaked do we?) Also after some updates I found the 'Google' certificate of authenticity back in 'Authentication' tab in 'Software Updater | Settings button'!

Why Opera inistead of Firefox? Well it is not just in this distro but Firefox, ABrowser (Browser in Zorin 10!), Midori, IceCat will NOT upload images! is now my default search engine! ;-) :D


Sun Nov 22, 2015 2:58:56 pm

You too can have the joy of Cinammon DE - it had been pulled by Ubuntu but you can get it back - see here: ... ppa-stable

which links to here: ... u/cinnamon

Open a terminal and add the repository:

sudo add-apt-repository ppa:lestcape/cinnamon

you will be asked for your login password, then update:

sudo apt-get update

Then open 'synaptic package manager' and search for 'Cinammon' - you will need to ensure you install 'Cinammon Session'! :) :D

Update: Tried this [] in Zorin 11 and it did not work as repos marked as outdated - just trying this for 16.04 (Yes I know Zorin 11 is based on 15.10! :D )


Sun Nov 22, 2015 5:56:36 pm

Well here we are with Zorin 6 themed cinammon desktop:


Zorin 8:


Zorin 10:







Sun Jan 03, 2016 12:06:25 pm

OK, just thought I would share this with you - Zorin 9 32-bit normally comes with Flash support - I disabled removed this somehow, can't remember - check my modification posts above.
Just to say I use Firefox with Flash add-in to view videos - not really needed any more as I used Synaptic Package Manager to search for 'gnash' - this is a gnome based flash-player that forum members reported not working - well I am pleased to say it is now working in Opera 12.16 - tested with one of my uploads. (

To install using Synaptic Package Manager go to Menu | System Tools | Administration | Synaptic Package Manager (or just enter 'synaptic' in the search box - note also that search does not like capital letters I have found! - possibly because in the terminal there usually are no capitals which use the commands to run the application?!) - remember you will need to enter your login password to access synaptic:



Sun Jan 03, 2016 5:48:51 pm

[Totally rewritten on 9.1.2016] It happened again today (loss of indicator-3 applet) so I have taken the opportunity to do step-by-step screenshots of condition and recovery process - and something else - in my original post on this issue I stated you can drag the indicator-3 applet to where you want - now remember that Zorin specifically places the applet on the far right - I suspect putting it anywhere else causes issues - for me I wanted to have the 'show desktop' at the end of the panel (like Windows) and wonder if this is what is causing the issue? Anyway here are the screenshots from my modified Zorin DE (default):

1. Missing indicator-3 applet (needed for powering off as I replaced Zorin Menu for GnoMenu):


2. Right-click the Panel to select 'Preferences'


3. Switch to 'Applets' Tab when 'Preferences' window appears:


4. Select the applet that is having issues in the 'mirrored' panel at bottom of 'Applets' tab by left-clicking it then click on the 'up' button to de-activate it:


5. Now as you can see the 'indicator-3 applet' has been removed from the panel leaving just the 'weather' applet and 'show desktop' applet:


6. Now scroll-down the main window in 'Applets' tab to find 'indicator-3 applet' once more - the simplest way to do this at this point which is what I did is to 'double-click' it with left mouse button:


7. 'Voila!' - the applet is back on show again:


Now I don't know if moving the indicator-3 applet is an issue, bear in mind I have seriously modified my Zorin DE to have a transparent panel and to get GnoMenu back:


which does not affect the panel as such, it is just an observation that the Zorin Menu' and 'indicator-3 applet' are like 'bookends' (the best analogy I could think of at time of posting!):


[UPDATE 10.1.2015] Well it is still disappearing so I have given up on this one - this is what I have now (only downside is no nm-applet (network manager applet)]:

Nearest to 6.jpg

The only issue I have is that I have had to use the 'Cairo Menu' in the Applets Tab to get the look of Zorin 6 back - couldn't replace the old logo on GnoMenu - even though I renamed existing logos in the Button folder of Themes! :lol:


Sun Jan 10, 2016 10:51:36 pm

New Topic: Introduction to Synaptic Package Manager - but before we even go there something we need to take care of first! Software Updater! (Menu | System Tools | Administration | Software Updater:

1. Let it do its thing first:


2. After it has finished, click on the 'Settings' button:


3. This is where it opens at - 3rd Tab along 'Updates':


Ensure that checking for latest release of Ubuntu is ALWAYS set to Never - unless you want a broken Zorin system! ;) :D

4. 'Other software' tab next:


As you can see, there are a lot of duplicate entries here - we need to uncheck all the duplicate entries after the first one, and ensure all (source code) entries are unchecked - otherwise Synaptic Package Manager will warn you of duplicate entries when you try to update from there! If you are brave enough you can delete the duplicate entries and duplicate (source codes) leaving just the first one:


If you are unsure, and BEFORE leaving/closing this tab, click on the 'Revert' button to restore it to the way it was - but you will have issues with synaptic - so if you want to play safe, just uncheck the duplicate entries:



Wed Feb 24, 2016 1:28:24 pm

Install gdesklets then look at what is available in the page above - there's even an 'eject' button for the DVD/CD tray - and it works! ;) :D


Wed Apr 13, 2016 11:45:12 am

OK - this should solve anyone having issues with Arista Transcoder having missing plugins from working correctly in Zorin 11:

1. Add the following repository via Terminal:

sudo add-apt-repository ppa:mc3man/gstffmpeg-keep

2. Whilst in the terminal after adding the repo:

sudo apt-get install gstreamer0.10-ffmpeg -y

with acknowledgements to: ... ug/1306592