
Where to obtain Zorin at No Cost?

This announcement has been made in response to an 
increasing number of issues reported either in the 'Installation' 
section of the forum or the 'Help and Support' section.

1. DOWNLOAD - from 1 of the following sites: 

http://ftp.heanet.ie/mirrors/zorin/

http://ftp.nluug.nl/os/Linux/distr/zorin/

ftp://ftp.aarnet.edu.au/pub/zorin/

http://distro.ibiblio.org/zorin/  <- mirror of last resort as you 
cannot resume downloads from this mirror if your internet 
connection drops during download (speaking from personal 
experience!)

The Browser that Zorin recommend is Firefox - I can also 
recommend Opera - both these browsers have the 
functionality to pause a download and resume at a later time - 
also useful if you lose a connection during download but 
please pay heed to my warning about ibiblio.org.

2. CHECK - the integrity of the .iso file you have downloaded 
BEFORE doing anything else. Download winmd5free from 
http://www.winmd5.com - instructional video here: 

http://www.veoh.com/watch/v28335038JpeNGXzP

3. BURN - at slowest speed - again from experience 'imgburn' 
is the most consistent CD/DVD burner - never had a coaster 

http://ftp.heanet.ie/mirrors/zorin/
http://www.veoh.com/watch/v28335038JpeNGXzP
http://distro.ibiblio.org/zorin/
ftp://ftp.aarnet.edu.au/pub/zorin/
http://ftp.nluug.nl/os/Linux/distr/zorin/
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made using this windows program - available from here: 
http://www.imgburn.com 

always choose the imgburn mirror as the download location - 
last mirror in the list given on their download page. Instructions 
on how to use are in the video link above. But before burning, 
and if you have not done this for a while (or never done it!) 
invest in a CD/DVD lense cleaner - this is basically a CD with 
either a straight row of bristles on the underside or some 
'spikes' as in the Allsop lense cleaning CD which also tests 
and tweaks your sound system but not needed to be 
undertaken as this element is really for hi-fi. Also make sure 
you use a decent brand of DVD to ensure a quality burn - if 
you have had consistently good burns with one particular 
brand then try and stick to that. This will reduce the event of 
creating a top quality 'coaster'!

4. INSTALL - If you intend to have Zorin as the only OS on 
your system then let the installer do it's own thing. If not then 
see Part 1 of my video on how to install Zorin alongside 
windows - the video shows an install alongside a machine 
having both XP and 7 on it already and the link is here:

http://www.veoh.com/watch/v283328437Pyp3Byy

Finally - ENJOY Zorin!

http://www.veoh.com/watch/v283328437Pyp3Byy
http://www.imgburn.com/


Installation of GNU/Linux alongside Windows by 
swarfendor437

Hi once again. Here I shall attempt to layout the correct 
procedure, from download to install of GNU/Linux alongside of 
Windows. AMENDMENT A. If you are running Windows 7, just 
in case there is an issue, be sure to create a 'Windows Repair 
Disc' should anything go wrong. Preferably install Zorin 
manually as outlined in my video on veoh.com which is in 3 
parts - the first one is here 
[ http://www.veoh.com/watch/v283328437Pyp3Byy] - but refer 
to the written text here first 1. Download your favourite flavour 
of GNU/Linux - remember if you have a 64-bit processor 
download a 64-bit version, however, there is nothing wrong 
with using a 32-bit version on a 64-bit based system; you 
cannot however put a 64-bit distribution (whether Windows or 
GNU/Linux) on a 32-bit based system. I have had no problems 
downloading *.iso's using Opera Web Browser. After download 
you will want to check its integrity by using winMD5 Free from 
here:  

http://www.winmd5.com

[If you have a GNU/Linux distribution already installed and 
running K3b burning software this has an md5 checker built-in 
- superior to Brasero in this area]. 2. Once you are happy that 
the MD5 checksum (usually available as a .txt file on the 
download page of the distribution) burn the image with 
Imgburn [from here: 

http://www.imgburn.com/index.php?act=download.]

http://www.imgburn.com/index.php?act=download
http://www.winmd5.com/


Installation of GNU/Linux alongside Windows by 
swarfendor437

3.  After you have burnt your CD/DVD (dependent on size of 
*.iso) check that it will run OK on your machine by running it in 
Live Mode - the distro will only use Memory - nothing will harm 
a Windows installation but Windows might report that 
something has happened and wants to take remedial action - 
don't be alarmed - possibly built-in FUD by Microsoft (Fear 
Uncertainty Doubt!).  If you are happy with how the distribution 
is performing in Live Mode there are some things you should 
do before going any further. 

4. Remove your Live CD/DVD and re-boot back into Windows 
and after booting into windows run CHKDSK on all of your 
partitions. 

5. After CHKDSK defragment all of your drives. 6. Shrink your 
Windows Partition to a reasonable size to allow space for your 
Linux Distribution. To minimize problems, on large Hard drives 
(400 Gb and above) I would be tempted to restict the main 
Windows partition to something like 120 Gb with another 120 
Gb set aside for Windows Data/Users. If you have just got 
Windows on the Hard Drive then go for something like 160 Gb 
tops. Next in Windows 7 Search pane of the menu enter 
Computer Management – if not expanded click on Storage 
and then Disk Management – after a few seconds the Virtual 
Disk Manager will launch – left click on the graphical 
representation of C:\ drive and right click it and select 'Shrink 
volume' to resize your Windows partition. If you would prefer 
to use a Disk Management tool then use Ranish Partition 
manager or for paid solution I would reccomend Acronis Disk 
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Director. Once you have resized Windows run CHKDSK 
again, reboot into Windows - it might request a restart - do so. 
6.  After 3rd Reboot into Windows run Defragmenter for 
analysis of the new drive - if it recommends you Defrag the 
drive do so. 

7. Put your live CD/DVD into your Optical Drive and boot from 
it - you may need to go into the BIOS to change your settings 
for older machines - this is usually accomplished by pressing 
the DELete key during boot - proprietary brands will differ e.g., 
Dell is F2, systems with obscure AMD motherboards like old 
ASUStek ones will need F8 pressing. Once in the BIOS look 
for a page with BOOT or Boot Priority - either on a Tab or on 
one of the other pages (Advanced settings for example). On 
newer machines a Function (F#) key will have been assigned 
to do this task - F12 on Dell computers and Laptops, Esc on 
HewlettPackard desktops and laptops, F11 on MSI 
motherboard configured systems for one time boot priority - 
you will get a list of all devices attached that can boot (if 
enabled in BIOS) - Hard Drive, Floppy Drive, CD-Rom, 
Network Card. 8. If you want to keep things straightforward let 
the distros installer do the work for you - Ubuntu based 
distributions (including Zorin) should come up with the option 
at point of install to install alongside your existing Wndows 
installation - all the partitioning etc will then be undertaken by 
the distribution make it the easiest option. If you want to 
manually assign partitions you will need to launch 'gparted' or 
'parted' - on some distributions the 'g' has been dropped - you 
can even download 'gparted' as a standalone boot system for 
partitioning: http://gparted.sourceforge.net/livecd.php you will 
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need to create a swap partition double the size your memory - 
unless you are building a server - for more details, please 
check this article: 
https://www.linux.com/news/software/applications/8208-all-
about-linux-swap-space

Next create a partition that should be formatted to the file 
system 'ext4' - avoid Reiser - I believe I might have lost an 
awful lot in the past thanks to this wonderful system! (or it 
could have been a hard drive fault). You will need to mark the 
ext4 partition as '/' [without the quotes] so that the MBR will 
see it is active and bootable - I would be tempted to make the 
'/' partition primary if you want to boot successfully into 
GNU/Linux. You may want to consider creating a separate 
/home partition where all users documents etc will be stored - 
you should think carefully how big you want /home to be 
depending on what you are going to use the system for - if 
video editing etc you will want to give it some decent capability 
- I don't want to give a number here - that's for you to decide. 
If you do create a separate /home partition you can remove 
the installed distribution which will leave your personal data 
intact (provided you don't have hard drive failure of course! - 
so backup, backup, backup!).

8. Once you have partitioned and you go back to the installer, 
point it to the right partition marked '/'. When you are asked at 
the end of installation about installing GRUB you want it to be 
in the MBR - NOT at the start of the partition - if you do this 
you will have to do some messing around with the Boot.ini file 
(in Windows XP) and cannot guarantee this will work - I have 

https://www.linux.com/news/software/applications/8208-all-about-linux-swap-space
https://www.linux.com/news/software/applications/8208-all-about-linux-swap-space
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never tried it but I have seen a laptop with XP and Mandriva 
set up this way. Be sure to make a note of whether you have 
capslock on when entering account names - GNU/Linux will 
not accept any capitals in user accounts (Real Name yes but 
not User) and if you put CAPS lock on whilst entering user 
password or mixture of upper and lower case and numerals be 
sure to make a temporary record somewhere until you are 
confident you no longer require your paper-based prompt. 

9. If you are installing Zorin to a wireless enabled laptop you 
will have to connect it wired to the router as GNU/Linux (most 
recent incarnations) use restricted drivers that are not present 
on the CD you burnt - you have to connect to the internet to 
download these and you have to accept the usual licence 
agreement before download (because they are Windows 
based drivers re-aligned so-to-speak, to run under GNU/Linux 
- diehards will not accept such an agreement and will wait until 
ndiswrapper or madwifi come out with a 'pure' GNU/Linux 
driver. One reason why my other favourite distribution is 
Ultimate Edition 2.7/2.8 as the drivers are already in the iso so 
no need to connect to the internet to get these. It is possible to 
customise installation down to partitions created for: /etc, 
/var /usr - one distribution that did this automatically was 
PCLinuxOS 2007 but I always thought the allocations for 
these to be quite small - especially /home that was limited to 
something like 10 Gb. I hope this 'tutorial' has been useful for 
you. Caveat: E&OE

UPDATE.
Please note, this article has been updated in light of up-to-
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date information on sizing of swap partition and other 
information on swap file - a link has been added to the article 
which is well worth reading: 
https://www.linux.com/news/software/applications/8208-all-
about-linux-swap-space
Video guide based on Zorin OS4 64-bit installation alongside 
both Windows XP and Windows 7 on the same machine:

http://www.veoh.com/watch/v283328437Pyp3Byy

Assistive Technology:

Using Compiz to make the desktop easier to see:

http://www.veoh.com/watch/v40627503jxeaQkAQ

Customising Zorin.

http://www.veoh.com/watch/v41286667XnDctAT8 – Part 1

http://www.veoh.com/watch/v41302485NS8wDS7g – Part 2

http://www.veoh.com/watch/v41302485NS8wDS7g
http://www.veoh.com/watch/v41286667XnDctAT8
http://www.veoh.com/watch/v40627503jxeaQkAQ
http://www.veoh.com/watch/v283328437Pyp3Byy
https://www.linux.com/news/software/applications/8208-all-about-linux-swap-space
https://www.linux.com/news/software/applications/8208-all-about-linux-swap-space
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I write a bash script for modifying Ubuntu-based distributions, 
adding/removing applications and customizations to fine tune 
the script. It's well-commented inside of it so the absolute 
beginner to bash scripting can understand the order of the 
script, what and why it's setup like it is.

I'm also 100% open to any and/or all suggestions for 
improving it.

Project Site and Download:

https://sourceforge.net/projects/ubuntune/

After download, from the terminal, do: 

$ sudo chmod +x ubuntune-1.50.31e.sh && sudo 
./ubuntune-1.50.31e.sh

There's a few spots where user interaction is required, and I'd 
also paste the entire script's code here, but when I tried to do 
that, I hit the board limit with this error (which is probably due 
to my comment lines inside of the script)

"Your message contains 105276 characters. The maximum 
number of allowed characters is 60000"

https://sourceforge.net/projects/ubuntune
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IT IS IMPORTANT YOU FOLLOW THE UPDATE PORTION 
OF THIS GUIDE!!!.

(See this link: 
http://www.zoringroup.com/forum/viewtopic.php?f=6&t=2247)

Hi all,

this How-To (guide) is for people who have successfully 
installed Zorin 6 Final and wish to do some post install 
configuration, these are my preferences, you must decide 
whether you wish to use the same settings/method as mine!. 
(Please do not confuse Zorin 6 Final with Zorin 6 Lite!!!)

Start your PC and log in to your new Zorin desktop, I will be 
using Gnome 2 as my example so if you wish to use the 
Windows 7 desktop, please ignore the bits that don't apply to 
you. 
(If you do want to use the Windows 7 desktop; make sure you 
add another AWN panel and set it to the top of your desktop, if 
you don't, when you minimize an open prog, it may well 
disappear and you won't be able to access it again!!. It 
happened to me in a test version of Zorin 6RC in Windows 7 
mode!!. Also you might want to add the package "awn-applets-
all" which is a meta package for AWN.)

To install the meta package I was referring to, open a terminal 
and paste this command:

sudo apt-get install awn-applets-all

http://www.zoringroup.com/forum/viewtopic.php?f=6&t=2247
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2 links for the Avant Window Navigator (AWN):

http://ubuntuforums.org/showthread.php?t=1714111

http://wiki.awn-project.org/FAQ

For more info about the AWN (Avant Window Manger), please 
see below.

You might get a message about language support pop up, you 
can ignore it for now.

Your current desktop should have the panel at the bottom, 
(When you start after first boot, your desktop will have the 
Win7 look!) click on the left button and type “look” in search, 
the Zorin Look Changer will appear, open it and select Gnome 
2, your desktop should change automatically and you should 
now have a Gnome 2 desktop, log out and back in again just 
to make sure it works!!.

Click on “Applications” > “Accessories” and then drag 
“Terminal” to the top panel beside “Places”, Go to 
“Applications” “Internet” and drag “Google Chrome” to the top 
panel, start Google Chrome and type in the address bar 
“medibuntu repo”, 
(https://help.ubuntu.com/community/Medibuntu) and then go 
to the section “Adding The Repository”, add the 2 commands 
one after the other in the terminal, once the Medibuntu 
Repository has been added, you can close the terminal.

https://help.ubuntu.com/community/Medibuntu
http://wiki.awn-project.org/FAQ
http://ubuntuforums.org/showthread.php?t=1714111
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Click on “Applications” > System Tools > Administration > 
Synaptic Package Manager and drag it to the top panel, start 
Synaptic and go to “settings > File > Delete files after 
download so you don't have any rubbish (trash to the Yanks) 
in your cache after the installation of software.

Now go to “Settings > Repositories > Zorin Software and 
mark all available boxes and make sure that the download 
location is set to “Main”, move to the next window “Other 
software, and do the same tick thingy, now go to updates and 
do the same again. Close the Software Sources window and 
click on “Reload” > “Mark All Upgrades” > “Apply” and let it 
do its thing, restart your PC after the updates have finished. 
(Updates may remain blank but are already listed in "Other 
Software")

Now install your graphic card drivers via the System settings 
menu, right click on the top panel Computer Icon > “System 
Settings” > Hardware > Additional Drivers and select the 
“Recommended version for your card, install them 
(“Activate”) and restart your PC. (ATI and Nvidia only!)
(Attention nVidia card owners, there might be a problem 
with pages going blank on you, please see this link:

http://www.zoringroup.com/forum/viewtopic.php?f=5&t=2490

You can use this PPA for the latest Nvidia drivers:
(add the commands one after the other in a terminal)

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

http://www.zoringroup.com/forum/viewtopic.php?f=5&t=2490
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sudo apt-get update

sudo apt-get install nvidia-current nvidia-settings

Restart your PC afterwards!!!!!

Now you need to install a few packages which you will need to 
adjust settings on your PC, open Synaptic and type “dconf-
tools” and mark it for install, do the same with “gdebi” and 
then click on “Apply”, once the packages are installed; close 
Synaptic.
(dconf-tools is the new configuration editor for Gnome 3 and 
gdebi is a single deb package install tool)

Dconf-Editor Settings:

Click on Applications > System Tools > dconf Editor and 
drag it to the desktop (see below for info about adding icons to 
the desktop) and then double click it to open it. Once dconf 
has started you might want to make a couple of changes, the 
following are some important ones I used:

Show date and day in clock:

Dconf Editor > Com > Canonical > Indicator > Datetime > 
Show Date/Show Day
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Change global font size:

Dconf Editor > Org > Gnome > Desktop > Interface > Text-
scaling-factor 1.0 (1.0 = font size 10. and 1.1 would be font 
size 11 and so on) (Mine is set to 1.2 = Font size 12)

Change icon size on desktop:

Dconf Editor > Org > Gnome > Nautilus > Icon-View > 
Default-Zoom-Level = Small

Show/Hide buttons:
Dconf Editor > Org > Gnome > Gnome Panel > Layout > 
Toplevels > Top Panel

Show/Hide Desktop icons = Trash/Computer/Home;

Dconf-Editor > Org > Gnome > Nautilus > Desktop

Stop Media Auto Mounting:

Dconf Editor > Org > Gnome > Desktop > Media-Handling 
> Automount/Automount-open/Autorun Never

Extra Desktop Themes:

If you want a couple of extra themes, type “gnome themes” in 
synaptic and install some or all of the available themes 
packages, make sure that the themes you are installing are 
labelled with gtk3 as gtk2 is the old gnome 2 system and won't 
work unless the theme says gtk2/gtk3. This will give you a few 
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more desktop and window themes which you can change 
using Ubuntu Tweak. Remember that “Gnome Shell” themes 
won't work with Zorin 6 because “Gnome Shell” is not 
installed!!  You can install 3rd party themes from Webupd8 
using the following command in a terminal:

sudo add-apt-repository ppa:webupd8team/themes

Then:

sudo apt-get update

For 3rd party themes: http://www.webupd8.org/2012/01/spice-
up-your-desktop-with-these-5-cool.html

Adding other user accounts:

You should also install the package "gnome-system-tools" 
which will add an icon in the main menu under "Users and 
Groups", armed with this tool you can setup accounts and 
how the guest accounts react with the OS, you can select how 
much access the guest has with regards to network or printing 
and other areas of the PC!!

http://askubuntu.com/questions/66718/how-to-manage-users-
and-groups

Extra wallpapers:

If you want extra wallpapers, open Synaptic and type 
“wallpaper” in search and mark all the packages that contain 

http://askubuntu.com/questions/66718/how-to-manage-users-and-groups
http://askubuntu.com/questions/66718/how-to-manage-users-and-groups
http://www.webupd8.org/2012/01/spice-up-your-desktop-with-these-5-cool.html
http://www.webupd8.org/2012/01/spice-up-your-desktop-with-these-5-cool.html
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the word “wallpaper”, don't mark packages that say “Artwork” 
otherwise your splash screen will change!!

Afterwards, right click on desktop > Change Desktop 
Background and select your pic!!.

Gnome Shell:

If you want to install "gnome-tweak-tool", you must also 
install "gnome-shell", please be advised that ZorinOS 6 Core 
was not designed with Gnome shell in mind although it works 
fine; with it installed. Please note that you use it (Gnome shell) 
at your own risk!!.

Now you can check to see if the language packs updated, 
open > System Settings > Language Support, if a message 
doesn't appear straight away, you are okay for language 
support, you can of course add or remove languages too.

Now you can continue adding your progs and favs.....done!!.

Adding icons to the Gnome 2 top panel:

I did mention about adding icons to the top panel by simply 
dragging them, this is how to do it in one hit.

Press Alt +Super (Windows key) then right click on top 
panel > Add to panel > Application launcher >then add the 
icons you want from the list.

To remove icons: Alt + Super > right click over icon you want 
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to delete then on "Remove".

Adding icons to the desktop:

If you add icons to the desktop by dragging them or right click 
and add to desktop, you may only have a white blank icon, 
right click on the icon and then on properties and permissions, 
then put a tick in the box "Execute". This will allow you to run 
the app directly from the desktop.

More info about the AWN (Avant Window Manger)

Changing default start button icon:

Right click > Start Button > Preferences (not Dock 
Preferences) > Button Selection > Install > then point it to 
the image. (or use the ones in the small list when you click on 
the right hand button in "Button Selection").
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Adding a second AWN panel to your Window7/XP desktop:

Right click the bottom panel > Dock Preferences > 
Preferences > Add Dock > Orientation > Top > Behaviour 
> Intellihide (assuming you want it hidden when not in use!) 
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Also click on Start AWN automatically.
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Adding applets to the taskbar:

Right click AWN panel > Dock Preferences > Applets and 
select the applet you want with a double click or mark it and 
click on the down arrow beneath the right window pane.

If you have any comments or suggestions, please share them 
with everyone so we can all get it right!!.

I hope that this guide has been of use to you.

Regards Wolfman 
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Gnome 2 look:
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Win7 look on my Nvidia rig:
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Win7 look on my ATI rig:
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Gnome 2 with Gnomish Dark theme:
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Windows 7 on my Nvidia rig July 2012
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Installing themes:

open Synaptic and type "gtk3 themes" in search, if you added 
the webupd8 PPA; you should have a list like mine:
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Assuming you installed the webupd8 PPA, type "gnomish" in 
Synaptic search and install "gnomishgray-theme" and use 
Ubuntu Tweak to set it in themes. This will give you a nice dull 
grey background.
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My home:
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I think if you leave the icon theme as "ZorinOS", it shouldn't be 
a problem, if you change the icon theme to something Ubuntu-
ish, I think it will change the button too!!.
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To get Zorin orb back look in the preferences again and in the 
2nd window, use distro icon instead of button!!
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I changed the text to:

Gnome Shell:
If you want to install "gnome-tweak-tool", you must also install 
"gnome-shell", please be advised that ZorinOS 6 Core was 
not designed with Gnome shell in mind although it works fine; 
with it installed. Please note that you use it (Gnome shell) 
at your own risk!!

… your quote "Neither the gconf-editor nor the Ubuntu 
Tweak tool would delete the icons from the desktop" isn't 
quite right, you can take out the main system icons from the 
desktop using Dconf-Editor.

Dconf-Editor > Org > Gnome > Nautilus > Desktop and take 
the ticks out.

Any other icons you added can be sent to trash with a right 
click.
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...you should have version 0.12 of dconf-tools installed and 
you should have "Org" which is the 5th entry on the left hand 
tree!!.

To add a pic, click on "Upload attachment" > Browse > Select 
the pic and Add > Add the file (After telling it where the pic is) 
> Place inline.
(Upload attachment is just below the box where you are 
typing!!)

You are running Zorin 6 Core Final and not Zorin 6 Lite aren't 
you????. Zorin 5 and Zorin 6 Lite have Gconf Editor not 
Dconf-Editor which doesn't have "Org".
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[Interjection by swarfendor437:

It doesn't always show up in the forum post either sometimes! 
But a refresh of the page may sometimes rectify it. What you 
have to do is (after using screenshot) it is saveds as a .png - 
open it in 'Image Viewer' and save as a .jpg. - You can save it 
wherever you like - default is desktop from memory - or 
possibly 'Pictures' in your home folder.

So,
1. Start post,

2. Click on 'Upload attachment' below 'post' screen where you 
enter text.
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3. Click on 'Choose ...' and browse to the .jpg file, then click on 
the 'Add the file' button.

4. Wait for the screen to refresh, go into the post and place the 
'I-beam' at the end of your submitted text, then press 'Enter' 
key to wrap to next line.

5. Click on the 'place in-line' button - then click on 'Submit' (or 
try Preview if you prefer).]
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Clarity on a different point:

I didn't say anything about installing that PPA, all I was saying 
was to install the meta package with this command:

sudo apt-get install awn-applets-all

I don't know where you even got the testing PPA from!!.

If you can remember to update immediately after an install; 
then my advice is to do so, otherwise; just follow my update 
guide should you have problems.

You only need Boot Repair should you have a problem with 
GRUB.
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System Update:

Assuming you have already installed and are now looking for 
some assistance in some way, you can ignore this first part if 
you already started you system for the first time, this is merely 
a suggestion.

Immediately after installing your system I recommend 
booting into "Recovery Mode" (don't do a first boot but boot 
straight into "Recovery Mode") and running "dpkg" (see 
below about cable connection), once you have run dpkg; and 
you re-boot, set your "Software Sources" (see below) list and 
update again due to the changes made to the software 
sources lists!!. (I know this may sound strange but its 
something I found that seems to work well for me!)

To update your system fully, use the following commands 
in a terminal:

sudo apt-get update

then run:

sudo apt-get dist-upgrade

The first command will update your package list, the second 
command will update the packages and any missing 
dependencies ; if there are new versions available.

You can also run both commands at the same time if you wish 
to do so:
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sudo apt-get update && sudo apt-get dist-upgrade

I tend not to do this just in case there are error messages, 
although it won't hurt if you do.

Forcing an update:

to force an update, do this one first:

sudo apt-get update

followed by:

sudo apt-get dist-upgrade -f

The only difference about the force command is the "-f" at the 
end of the command which denotes the "force" part of the 
command.

(Same as above):

sudo apt-get update && sudo apt-get dist-upgrade -f

You can also do the same as the above commands using 
Synaptic, open Synaptic and click on "Reload" then "Mark All 
Updates" and lastly on "Apply". (Except the force part!!!!)

Make sure that your sources lists are active and set to "Main". 
You can do this via Synaptic > Settings > Repositories
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https://help.ubuntu.com/community/SynapticHowto

https://help.ubuntu.com/community/PackageManagerTrou
bleshootingProcedure

Replacing Files:

Sometimes when updating you will be asked if you want to 
replace an existing file with a new one, the normal default 
action is to say no, I on the other hand find it better to install 
the new one, you must decide yourself whether or not you 
wish to do the same, I recommend replacing the existing 
file with the new one!! (Use at your own risk but I have 
never had a problem doing just that!)

Software Sources Settings:

If you have a problem with the software sources update, 
please see this How-To which should give you tips on how to 
keep your system fully updated.

I recommend using the "Main" repository download link!!

https://help.ubuntu.com/community/Repositories/Ubuntu

https://help.ubuntu.com/11.10/ubuntu-help/addremove-
sources.html

https://help.ubuntu.com/community/SynapticHowto
https://help.ubuntu.com/11.10/ubuntu-help/addremove-sources.html
https://help.ubuntu.com/11.10/ubuntu-help/addremove-sources.html
https://help.ubuntu.com/community/Repositories/Ubuntu
https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure
https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure
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These are my settings, use at your own risk!.

S
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If you cannot click on the "Updates" section of "Software 
Sources", please don't worry about it, they are already listed in 
the "Other Software" window.

I also recommend using the Getdeb PPA to help keep the 
system up-to-date:

http://www.getdeb.net/welcome/

Changing download location:

http://www.getdeb.net/welcome/
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If you are having a problem with the downloads, you can 
change the download location with:

Open Synaptic > Settings > Repositories > Download From > 
Choose a country and select best server, close the windows 
then reload and try updating again.

Fixing Broken Packages:

There are often posts on the forum about "Broken Packages", 
you can solve this problem by opening: Synaptic > Edit > Fix 
broken packages. (You may well already be in Synaptic when 
you see this message!)

You can also run a command to fix this; run this command in a 
terminal:

sudo dpkg --configure -a

The third option is to restart your PC and go into "Recovery 
Mode" and run "dpkg" in the list. When asked if you should 
continue, press "y" (for yes even if it says that there are no 
updates available) and then enter, this will run any updates 
and repairs it needs to!! You may have to run "fsck" before 
"dpkg" appears in the menu!! 

This option requires a working cable network connection, 
it may not work with a WiFi connection!!. Click on "Network" 
to activate the network before trying to use the internet to 
update the system. (I could not get it to work with WiFi)
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Error messages about "Duplicate Sources":

If you get error messages about duplicate source lists or 
similar, you can enter the following commands in a terminal to 
solve this problem:

sudo rm -r /var/lib/apt/lists/*

Then:

sudo apt-get update

The other option is to simply ignore them which won't make 
them go away, but it still works for me!!

Broken Upgrade or Installation

What to do if an installation process fails and you find it is no 
longer possible to install or remove packages:

Open a Terminal and type the following commands, pressing 
the Return or Enter key after each (you may have to type in 
your password):

sudo dpkg --configure -a

followed by

sudo apt-get install -f
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In order to complete some tasks in Ubuntu Gnome based 
Linux systems; it is necessary to make yourself into user root, 
you can do this by:

Pressing the Alt + F2 keys and type "gksudo nautilus"

(for Kubuntu: kdesu konqueror)
(for Xubuntu: gksudo thunar)

this will open a new window and you can do what you need to 
do as "root", as soon as you close the window; user root shuts 
down and you continue as a normal user.

It is important to note that while working as root; you are 
aware that whatever you are doing; will be done at an 
administrative level and any permissions given; are normally 
given to "root" only, if you feel you also need to create 
permission for a normal user, right click on the file or folder or 
package and go to > properties > permissions and select 
which user(s) you want to apply permissions to.

When you are asked for your "root" password, give your 
normal user password unless you created a specific 
password for "root".

See also:
https://help.ubuntu.com/community/RootSudo

and:
http://www.psychocats.net/ubuntu/permissions

http://www.psychocats.net/ubuntu/permissions
https://help.ubuntu.com/community/RootSudo
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nVidia White-Out problem – FIX!

Problem:

The screen goes white when more than one window is open, 
this is something to do with Compiz, the windows turn white 
one when more than one window is open and you try to switch 
between them.

Fix:

Open Compiz > Effects > Animations > Focus Animation > 
Highlight where it says "Focus Effect" - "Dodge" > Edit > 
Focus Effect > Select "None" > Close

Thanks to "gregeubarr" over on the Ultimate Edition 
forum:

http://forumubuntusoftware.info/viewtopic.php?
f=106&t=8632&p=72287#p72287

For the latest Nvidia drivers ( version 304.37 as of 
21.Aug.2012) please copy and paste the following commands 
one after the other in a terminal, press enter after each 
command is put in, you should only have to provide your 
password once:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

http://forumubuntusoftware.info/viewtopic.php?f=106&t=8632&p=72287#p72287
http://forumubuntusoftware.info/viewtopic.php?f=106&t=8632&p=72287#p72287
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sudo apt-get update

sudo apt-get install nvidia-current

Then restart your PC.



How-To set up DVB-T (S & C) (ATSC) under GNU/Linux (by 
Wolfman)

Anyone wishing to use a DVB-T (S&C) (ATSC in the United 
States) USB stick requires the firmware and either me-tv or 
Kaffeine to watch TV on their PC.

Please install "dvb-apps" and kaffeine and me-tv, also 
"linux-firmware-nonfree" for the hardware "Firmware" 
package (drivers) for your USB stick.

Anyone wishing to use Mythtv should be aware that there are 
3 main points to bare in mind when setting it up.

1. make sure you type something in "video source" like 
"sourcefile" or something, I simply typed "vidsource".

2. when setting up your DVB-T device, make sure that you 
mark it under "input".

3. leave the time zone set as "none" otherwise it cannot find 
your PC's IP address and comes back with error messages.

http://parker1.co.uk/mythtv_ubuntu.php

http://parker1.co.uk/mythtv_ubuntu2.php

If your DVB-T stick is not working, you may have to extract 
and copy the firmware files (not the folder but its contents) into 
/lib/firmware as root and restart your PC with your stick not 
inserted; once your PC has booted you can insert your USB 
stick; then open a terminal and type "lsusb" to see if your stick 

http://parker1.co.uk/mythtv_ubuntu.php
http://parker1.co.uk/mythtv_ubuntu2.php


is shown, if it is; then you are good to go and just need to scan 
for channels using Me-TV or kaffeine. (This is assuming you 
have DVB-T reception in your area!).

If it states (after typing lsusb) that the device is in a "cold 
state"; then you may well have to look for other firmware 
elsewhere because your device is not loaded correctly or not 
being recognized!!.

http://ns2.canonical.com/en/karmic/linux-firmware-nonfree

is the main firmware package from Ubuntu

and:

http://steventoth.net/linux/sms1xxx/sms1xxx-hcw-55xxx-dvbt-
02.fw

is the place for downloading the firmware for my Hauppage 
WinTV Aero usb stick.

My other usb stick is from "Skymaster" which is a German firm 
but the chipset is from Hanftek and the firmware for that is in 
the Ubuntu firmware bundle.

Another couple of links for you as info:

http://linuxtv.org/

http://linuxtv.org/wiki/index.php/DVB-T_USB_Devices

http://linuxtv.org/wiki/index.php/DVB-T_USB_Devices
http://linuxtv.org/
http://steventoth.net/linux/sms1xxx/sms1xxx-hcw-55xxx-dvbt-02.fw
http://steventoth.net/linux/sms1xxx/sms1xxx-hcw-55xxx-dvbt-02.fw
http://ns2.canonical.com/en/karmic/linux-firmware-nonfree


And this guy claims to have loaded (up to 2009) all firmware 
files in one package which you can download from here:

http://rapidshare.com/#!download|388tg|250533445|
linux_dvb_firmware_v2.7z|745

For those of you that like making and such, if you are having 
problems with an unsupported device, please go here:

http://linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_In
stall_V4L-DVB_Device_Drivers

Antenna (Reception) tips:

1. make sure your device is not near any electrical device that 
can cause interference like a DECT (cordless phone) 
telephone or a microwave oven; or even your PC monitor and 
PC can cause disturbance. (if you have an internal card; you 
should be okay on the last bit!).

2. if you have a roof antenna; make sure it is actually pointing 
in the right direction of the transmitter mast and covers the 
frequency given out by the transmitter, some older roof 
antenna don't cover all the newer DVB-T frequencies and 
some are only horizontal or vertical but not both, so make sure 
it covers both polarities. Some roof antenna also require 5 
volts of power so you might want to check that too but don't 
overload it!.

3. if you have an indoor antenna make sure it is an adjustable 
one with maximum decibels and that it is a mesh antenna 
because they offer better reception qualities. The larger the 

http://rapidshare.com/#!download%7C388tg%7C250533445%7Clinux_dvb_firmware_v2.7z%7C745
http://rapidshare.com/#!download%7C388tg%7C250533445%7Clinux_dvb_firmware_v2.7z%7C745
http://linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers
http://linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers


mesh, the better the reception. Also having a booster on it is a 
good thing.

4. if you live near a main road, traffic can cause problems 
because some vehicles give out high frequency signals.

5. stick antenna are okay if you live right on top of the 
transmitter but don't work too well if you are to far away, what 
the actual distance is I don't really know but they are subject 
to interference but work quite well outdoors!!!.

6. if you are using wireless lan (WiFi) during scanning; you 
may well get nothing but interference due to the signal from 
the WLAN router!!!!!. Switch it off!!!!!!.

Kaffeine:

http://kaffeine.kde.org/?q=faq

me-tv:

http://www.ubuntugeek.com/me-tv-digital-television-viewer-for-
gnome.html

A few more video links:

http://www.youtube.com/watch?v=kv2gHz2O4p4

http://www.youtube.com/watch?v=kv2gHz2O4p4
http://www.ubuntugeek.com/me-tv-digital-television-viewer-for-gnome.html
http://www.ubuntugeek.com/me-tv-digital-television-viewer-for-gnome.html
http://kaffeine.kde.org/?q=faq


And a mapping site that is really cool:

http://www.dvbtmap.eu/

DVB-T Wiki:

http://en.wikipedia.org/wiki/DVB-T

I hope that this is of use to you.

http://en.wikipedia.org/wiki/DVB-T
http://www.dvbtmap.eu/


Conky-lua modified by madvinegar for Zorin OS (by 
madvinegar)

I have prepared the following very easy guide in case 
someone would like to add to his desktop the conky-lua.
I have modified the conky so as to suit Zorin OS. More 
specifically I have done the following:

1) I have attached the zorin logo.

2) I have used blue colour (which is the color of Zorin).

3) I have modified the code so as to show the temp of your 
pc/laptop (which imo is very very useful).

4) I have modified the code to show the wireless 
upload/download values (not the ethernet ones) but it can 
easily be set to show the ethernet ones.

5) I have prepared a script that delays conky to load for 
30seconds so as to be safe that it will not conflict with the 
compiz 3d effects. No worries, it loads very fast.



So, lets start with the guide:
Firstly, ofcourse, download and extract the compressed file 
that I am attaching in the end of this post. Right-click on it and 
sellect "extract here".

Step1 - Install sensors

sudo apt-get install lm-sensors
sudo sensors-detect

You answer yes (y) to all questions.

Step2 - Install conky

sudo apt-get install conky-all

Step3 - Install neurpolitical font

Copy the neurpoli.ttf. file to /usr/share/fonts/truetype
This can be done through 

gksudo nautilus

in terminal.



Once the file has been copied to the "truetype" file, open it 
with font viewer and click on the button that says "install font" 
at bottom-right.

Step4 - Copy files to home folder

Copy the files ".conkyrc", ".lua", ".conky", 
".concky_script_startup.sh" to your home folder (the same 
folder where your Downloads, Documents, Music etc. folders 
are). 
Note that these files have a dot (.) in front of them. This means 
that they are hidden. You will have to press Ctrl+H to be able 
to view them.

Step5 - Make   conky_script_startup.sh   executable.  

Right-click the file, go to permissions tab and tick the box that 
says "allow executing as a program".

Step 6 - Add   conky_script_startup.sh   to   startup   
applications

Open startup applications and click on "new".  As name use 
"conky" and as command browse to your home folder and 
add conky_script_startup.sh. Again, you will have to press 
Ctrl+H to be able to view it as it is a hidden file.

That's it!
Reboot and some seconds after your desktop loads you will 
get this fantastic conky.
It works just great and I have tested it in Zorin 5 and Zorin 6.



http://www.zoringroup.com/forum/download/file.php?id=386

When you extract the downloaded file press ctrl+H to view the 
hidden files. 

Just for your ease of reference the script is as follows:

#!/bin/bash
sleep 30 && conky ;

I am giving a 30 second delay just to be sure that conky will 
not conflict with the loading of the desktop and the compiz 
effects.

http://www.zoringroup.com/forum/download/file.php?id=386

