WiFi disconnect after more than 1 day

WiFi disconnect after more than 1 day

Postby ryu_joko » Thu May 16, 2019 8:53 am

hi, im using Zorin OS 12 and 15 Beta, updated to latest.
im persistently get disconnect from wifi, its always get question mark on the wifi atfer 1 or 2 days on (since my students forgot to turn off). And it also get no internet connection easily, it says something like 'network discovery disable...Avahi incompatible' although cable work fine.

Im hoping wifi, hopefully it can work as good as cable.

heres the log from lspci:
user@user-Lenovo-S200z88934:~$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 35)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 35)
00:13.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SATA Controller (rev 35)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 35)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 35)
00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 35)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 35)
00:1c.2 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #3 (rev 35)
00:1c.3 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #4 (rev 35)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 35)
00:1f.3 SMBus: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx SMBus Controller (rev 35)
02:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth (rev 79)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
User avatar
ryu_joko
 
Posts: 6
Joined: Thu Mar 21, 2019 12:46 am

Re: WiFi disconnect after more than 1 day

Postby Swarfendor437 » Thu May 16, 2019 1:20 pm

Having read this thread (https://forum.manjaro.org/t/intel-3165- ... arts/50712) it appears to be a driver issue. Have you, whilst having connected to internet with wired, updated the system. Have you tried disabling Bluetooth to see if that helps as I see it is a hybrid wireless/bluetooth chipset. Also look at that thread more closely on how to disable power saving to ensure that wireless is always up when switched on. ;) :D

Your simplest alternative might be to buy a usb dongle that works with GNU/Linux - if you look on websites that sell used kit look for a Netgear WG111 v3 - they work out of the box - only support 2.4 Ghz but it works well. Alternatively WNDA 3100, also from Netgear - that one supports 5 Ghz band. Before I forget, in your wireless connections, for IPv6 set this to 'ignore', Also ensure that IPv4 is only used to make the connection and available to all users. ;) :D

Also check the possible solution here:

https://forums.linuxmint.com/viewtopic.php?t=258951
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 9458
Joined: Wed Sep 18, 2013 5:51 pm

Return to Help and Support

Who is online

Users browsing this forum: No registered users and 5 guests