Startup sounds in Zorin 12 Lite

Startup sounds in Zorin 12 Lite

Postby ian4238 » Thu Mar 29, 2018 10:21 am

Zorin 12 Ultimate is so slow starting up I installed a login sound effect, so I could go and make a cup of coffee. Recently I have tried to install the same sound in Zorin Lite (XFCE) but it does not work. From the menu Settings/Session & Startup/Application Autostart I added "Startup Sound (Sound on login)" Command: paplay /usr/share/sounds/purple/login.wav
This works in Ultimate, but does nothing in Lite. Can anyone suggest how to make it work - any sound will do.
I have never succeeded in getting a shutdown sound. Thanks.
User avatar
ian4238
 
Posts: 69
Joined: Tue Mar 29, 2016 2:02 am

Re: Startup sounds in Zorin 12 Lite

Postby Swarfendor437 » Thu Mar 29, 2018 1:05 pm

Hi try the solution here - it appears to work on xubuntu which is what Zorin 12 Lite is based on:

https://ubuntuforums.org/showthread.php?t=1869787

I think because of the 'demand' for quick shut downs, even though shut down sounds exist, it is probably a system issue that may need some sort of scripted delay - something I have been meaning to look at for some time:

https://vimeo.com/126311678
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11319
Joined: Wed Sep 18, 2013 5:51 pm

Re: Startup sounds in Zorin 12 Lite

Postby ian4238 » Fri Mar 30, 2018 5:31 am

Thanks for the suggestion. This is a very old thread relating to Ubuntu 11.10. I tried the exact instructions, and found that 'dconf Editor' was blank under all headings. After reading replies about Ubuntu 12.04 I tried:
sudo apt-get install sox gnome-session-canberra xfce4-mixer and came up with: Unable to locate package xfce4-mixer
Many people coming from Windows would expect to hear sounds, so I am surprised no-one has sorted this out over the years. I accept that 'shutdown' sounds are not practical.
User avatar
ian4238
 
Posts: 69
Joined: Tue Mar 29, 2016 2:02 am

Re: Startup sounds in Zorin 12 Lite

Postby ian4238 » Sat Mar 31, 2018 4:47 pm

I tracked down in the XFCE webpages - " pkgs.com/download/xfce4-mixer " - a download of 'xfce4-mixer' for Ubuntu 14.04 - the latest Ubuntu listed.
Downloaded it and tried to get gDebi to install it. Got the following result:
"Error: Dependency is not satisfiable: libxfce4util6 (>= 4.9.0) "
I think my version of XFCE is 4.12.1-2 What does this mean?
User avatar
ian4238
 
Posts: 69
Joined: Tue Mar 29, 2016 2:02 am

Re: Startup sounds in Zorin 12 Lite

Postby Swarfendor437 » Sat Mar 31, 2018 7:51 pm

Well you have a version higher than that needed which means it should meet the requirements, but suspect due to newer kernels and various library dependencies this isn't going to happen unfortunately. :(
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11319
Joined: Wed Sep 18, 2013 5:51 pm

Re: Startup sounds in Zorin 12 Lite

Postby ian4238 » Tue Apr 17, 2018 6:30 am

I have continued to experiment, and now have a startup sound rather like Tibettan gongs. What seems to have worked (and I don't know how or why) was:
settings-session & startup-application autostart-add
play /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
added names - whatever you like.
I went to: system-dconf Editor-org-gnome-desktop-sound but it was all blank under all headings, so ignored that.
Then went to: settings-settings Editor-xsettings-net--Sound Theme Name- changed the value from 'String' to 'ubuntu'
(without quotation marks)-OK
After rebooting the sounds were there, and work consistently.
This suggestion came from Xubuntu 11.10 forums in 2011. One of the recent updates must have changed things a bit. Eventually I hope to find some better sounds.
User avatar
ian4238
 
Posts: 69
Joined: Tue Mar 29, 2016 2:02 am

Re: Startup sounds in Zorin 12 Lite

Postby Swarfendor437 » Tue Apr 17, 2018 12:57 pm

Thanks for this - I installed xfce on my copy of Ultimate and been messing but not got very far - been looking at some xfce forum threads but I can't edit xsettings! :x

I will post you what I think is the best one with Music "Welcome! Please identify yourself." ;) :D
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11319
Joined: Wed Sep 18, 2013 5:51 pm

Re: Startup sounds in Zorin 12 Lite

Postby ian4238 » Tue Apr 17, 2018 1:55 pm

Don't know if this will help:
1. Clicked on xsettings
2. Went down list to 'Net'
3. Went down list to 'SoundThemeName'
4. Clicked on 'Edit'
5. New box Edit Property
Property: /net/SoundThemeName
Type: String
Value: ubuntu (Typed this to replace the word "String")
Cancel Save
Clicked on 'Save' and the rest is history.
User avatar
ian4238
 
Posts: 69
Joined: Tue Mar 29, 2016 2:02 am

Re: Startup sounds in Zorin 12 Lite

Postby Swarfendor437 » Tue Apr 17, 2018 10:05 pm

Sadly won't work for me - I will try reinstalling xfce. In the meantime...

system-ready.tar.gz
(143.35 KiB) Downloaded 67 times
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11319
Joined: Wed Sep 18, 2013 5:51 pm

Re: Startup sounds in Zorin 12 Lite

Postby Swarfendor437 » Mon Aug 27, 2018 2:25 pm

It's been a while - I still can't get 'system-ready.ogg' to play, but after installing Cinammon DE I can get Logiin sound and Logout sounds to work. :D
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11319
Joined: Wed Sep 18, 2013 5:51 pm

Return to Help and Support

Who is online

Users browsing this forum: Google [Bot] and 7 guests