CD playing back spoiled

CD playing back spoiled

Postby pcfan5 » Sat May 05, 2018 8:16 pm

Hello, I have many CD from my personal colection that I want to play in my computer, however since I turn into Linux word I cannot do so without getting buffering stuck , listening to the songs cutted and interrumpted. This is since Linux Mint (cinnamon, mate) and now includes Zoring... I don't know if it a problem in my CD/DVD device or a buffering issue.

I didn't ask febore since most of times I listen to mp3, howeer whenever I try to play an orginal CD it is all trouble, with any software (this includes VCL , parole, clementine).

I have 2 Sound cards in my sistem but one of them isn't very linux fliendly , so that I am using the on board device, but the PCI sound device is still attached to the harware.

this is my computer

Code: Select all
System:    Host: sil-MS-7529 Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Zorin 12 xenial
Machine:   Mobo: MICRO-STAR model: G31TM-P21 (MS-7529) v: 1.0
           Bios: American Megatrends v: V4.7 date: 07/28/2010
CPU:       Dual core Pentium E5300 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 10400
           clock speeds: max: 2603 MHz 1: 1268 MHz 2: 1816 MHz
Graphics:  Card: Intel 82G33/G31 Express Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.19.5 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1360x768@60.02hz
           GLX Renderer: Mesa DRI Intel G33
           GLX Version: 1.4 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 VIA VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
           driver: snd_ice1724 ports: ec00 e880 bus-ID: 03:00.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: d800 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 610.2GB (48.7% used)
           ID-1: /dev/sda model: WDC_WD400BB size: 40.0GB
           ID-2: /dev/sdb model: SAMSUNG_HD322HJ size: 320.1GB
           ID-3: USB /dev/sdc model: 2500BMV_External size: 250.1GB
Partition: ID-1: / size: 29G used: 10G (38%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 262G used: 92G (38%) fs: ext4 dev: /dev/sdb5
           ID-3: swap-1 size: 4.10GB used: 0.00GB (0%) fs: swap dev: /dev/sdb6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 195 Uptime: 2:25 Memory: 2319.6/3936.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


The CD/DVD device isn't shown here aI don't know how to do it. So that I leave you a capture of Disks

Captura de pantalla_2018-05-05_16-13-59.png




Thank you for reading this.
User avatar
pcfan5
 
Posts: 213
Joined: Fri Mar 09, 2018 1:03 am

Re: CD playing back spoiled

Postby Swarfendor437 » Sun May 06, 2018 12:21 pm

Hi, take a look at this archived thread. I suspect your VIA card needs alsamixer to be installed. You need to look at the last post about assigning the alsamixer command to the second card. I would also advise adding 'sox' and if at all possible, removing pulse-audio - but before you do, can you install 'paman' - pulse audio manager to see if that improves things? ;) :D
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS M5A78L-M/USB 3, AMD Phenom II x 6, 4 Gb RAM, nVidia Graphics GT620 (2 Gb)
User avatar
Swarfendor437
 
Posts: 8983
Joined: Wed Sep 18, 2013 5:51 pm

Re: CD playing back spoiled

Postby pcfan5 » Sun May 06, 2018 9:00 pm

Hi thank you very much for your kind replay, could you please send me the link to the archived thread...I suspect you were about to paste and forgot it :mrgreen: ;)

I am also worried that my CD device isn't working well :| Don't know how to confirm that.

Alsa mixer is present in my computer. Right now my speakers are plugged in the Realtek on board Card, I am not using VIA because it doesn't work with 2 channels (I can only plug my speakers in it but not my headphones)

I also think it has something to do with buffering or memory stuff, take a look at these errors I got.

This is while trying to play CD's with "parole", before the disk it is mounted for shure , for what I have to mount and unmount, and open/close the device try.
Captura de pantalla_2018-05-06_18-29-14.png



This is trying to run a performance test from Disks

Captura de pantalla_2018-05-06_18-33-32.png


I edit again to say than took the chance and unisntalled pavucontrol and pulse audio, but then lost alsa-tray, when trying to intall "alsa-tray:
Depends: hal but it is not installable" :( ( I was able to install with Synaptics python-alsaaudio , python-notify).

paman didn't do anything..
sox seems to be an equalizer or something like that.
User avatar
pcfan5
 
Posts: 213
Joined: Fri Mar 09, 2018 1:03 am

Re: CD playing back spoiled

Postby pcfan5 » Mon May 07, 2018 4:11 am

*off topic: regarding the tray notication it can be fixed her https://ubuntuforums.org/showthread.php?t=1987209
User avatar
pcfan5
 
Posts: 213
Joined: Fri Mar 09, 2018 1:03 am

Re: CD playing back spoiled

Postby Swarfendor437 » Mon May 07, 2018 4:52 pm

OK, here is the link for the soundcard issue:

https://ubuntuforums.org/archive/index. ... 13743.html

my other thoughts regarding the CD Player - have you ever used one of these?:

https://www.cnet.com/products/allsop-la ... sk/prices/
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS M5A78L-M/USB 3, AMD Phenom II x 6, 4 Gb RAM, nVidia Graphics GT620 (2 Gb)
User avatar
Swarfendor437
 
Posts: 8983
Joined: Wed Sep 18, 2013 5:51 pm

Re: CD playing back spoiled

Postby pcfan5 » Wed May 09, 2018 3:58 pm

Swarfendor437 wrote:OK, here is the link for the soundcard issue:

https://ubuntuforums.org/archive/index. ... 13743.html


Thanks for your replay!! ;) I will check this , however I must confess I acted like a crazy and installed sox, paman, uninstalled pulseaudio, pavucontrol, etc, etc, now my system is a mess, because I put my hands everywere, since alsamixer didn't show the sound icon in panel, and the "recipes" in ubuntu forum were difficult for me. So once I spoiled all the sound configuration, I had to install pulseaudio again with everything I encountered in the way within synaptics, now the sound icon doesn't activate by itself so I have to run in Terminal "pulseaudio" for it to work.

By the way the system is slow and browsers-mozila and chromium- are the worst. (Flash web sites are still giving me problems.. In Facebook case it doesn't show fully properly, takes a long time to load the page)

So all in all I am sad to say I have to reinstalled my OS

For all that matters Swarf I would like to add, that VIA PCI sound card isn't the one I am ussing since It is not linux friendly. I am intending to use my internal (on board) card.

[quote= my other thoughts regarding the CD Player - have you ever used one of these?:

https://www.cnet.com/products/allsop-la ... sk/prices/[/quote]

I have, but mostly I prefer opening my self the CD unit and cleaning it with a cotton stick.

Anyway from the forums I have read the problem regarding CD play back issue is long time ago dated in ubuntu, since pulseaudio came to life. (I think this is a big issue for programmers since most people are experiencing the same trouble) :roll:
User avatar
pcfan5
 
Posts: 213
Joined: Fri Mar 09, 2018 1:03 am

Re: CD playing back spoiled

Postby Swarfendor437 » Thu May 10, 2018 12:56 pm

OK, as it is the onboard card you would change the command from:

Code: Select all
alsamixer -c 1


to

Code: Select all
alsamixer -c 0


Also found this interesting thread on Pulse and ALSA:


https://askubuntu.com/questions/147981/ ... o-and-alsa
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS M5A78L-M/USB 3, AMD Phenom II x 6, 4 Gb RAM, nVidia Graphics GT620 (2 Gb)
User avatar
Swarfendor437
 
Posts: 8983
Joined: Wed Sep 18, 2013 5:51 pm

Re: CD playing back spoiled

Postby pcfan5 » Thu May 17, 2018 9:08 pm

Hello,. Thanks for your reply, where do I run the commands you gave me above?

Anyway, in alsa mixer run in terminal if I press F6 I am able to change and select the sound cards.

Importan: I am no longer undr Zorin Litte, I have a fress instalation of Zoring Core (after all the mess I have done)
User avatar
pcfan5
 
Posts: 213
Joined: Fri Mar 09, 2018 1:03 am

Re: CD playing back spoiled

Postby Swarfendor437 » Fri May 18, 2018 12:55 pm

pcfan5 wrote:Hello,. Thanks for your reply, where do I run the commands you gave me above?

Anyway, in alsa mixer run in terminal if I press F6 I am able to change and select the sound cards.

Importan: I am no longer undr Zorin Litte, I have a fress instalation of Zoring Core (after all the mess I have done)


In a terminal. ;) :D
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS M5A78L-M/USB 3, AMD Phenom II x 6, 4 Gb RAM, nVidia Graphics GT620 (2 Gb)
User avatar
Swarfendor437
 
Posts: 8983
Joined: Wed Sep 18, 2013 5:51 pm

Re: CD playing back spoiled

Postby pcfan5 » Fri May 18, 2018 3:10 pm

Hi again. I think right now the problem isn't the sound cards, I keep thinking it is a buffering issue, I have the same issue under linux mint in another computer (a laptop). Today in my Desktop PC, where I am now under Zorin Core, CD's aren't even read by the CD devide. Which I also think isn't working properly. So here we have a combination of both issues. Buffering, which is always been a problem , for what I have read and what I deal with in my laptop, and CD device. To make it short , I would like to know if anyone else has problems playing CD under Zorin. Because since I am thinking my device isn't workin well and I don't have another to try I cannot say for sure.
User avatar
pcfan5
 
Posts: 213
Joined: Fri Mar 09, 2018 1:03 am
Next

Return to Help and Support

Who is online

Users browsing this forum: No registered users and 5 guests