Graphics lagging on Left for dead (working in win10)

Graphics lagging on Left for dead (working in win10)

Postby Oxygen142 » Mon Sep 23, 2019 10:57 am

First up I would like to thank eveyone involved in Zorin OS. I am new to Linux in general and what a breeze to see this OS.

I don't have a extra graphics card in my PC so using a MSI -M5A78L-M/USB motherboard and a AMD hexacore CPU with 4 GB DDR 3 Ram. In windows mode Left for dead have no issues. Running it through Zorin OS which is installed on its own partition Left for dead load up very quick and everything is very quick except when its in the game.

Using the mouse and keyboard lags as well as the graphics on the screen itself which does not happen with Windows 10. Can someone please assist me what I should try and do?

Lastly when I run the terminal and check on the Graphics its showing AMD RS780 but somewhere else I saw Radaen 3000. Sorry I am not totally clueless but compared to you guys I definitely am.
User avatar
Oxygen142
 
Posts: 4
Joined: Mon Sep 23, 2019 10:13 am

Re: Graphics lagging on Left for dead (working in win10)

Postby Aravisian » Mon Sep 23, 2019 5:24 pm

Oxygen142 wrote:I am not totally clueless but compared to you guys I definitely am.

Watch who you are comparing yourself to, first. :P

Are you running Left for Dead on Steam, linux? Wine4 installed on Zorin?
Which Zorin OS version are you using, Zorin 12 or Zorin 15?

Can you hit ctrl-alt-t and open a terminal and enter
Code: Select all
lspci -v | less
and paste the VGA output here?
User avatar
Aravisian
 
Posts: 716
Joined: Sun Dec 30, 2018 6:51 am

Re: Graphics lagging on Left for dead (working in win10)

Postby Oxygen142 » Mon Sep 23, 2019 5:54 pm

Hi

Running Left For Dead copied without Steam. Running it through Wine and using Zorin 15.

Thanks for your help I really appreciate it. Output as requested below.

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS780 Host Bridge
Subsystem: ASUSTeK Computer Inc. RS780 Host Bridge
Flags: bus master, 66MHz, medium devsel, latency 0, NUMA node 0
Capabilities: <access denied>

00:01.0 PCI bridge: ASUSTeK Computer Inc. AMD RS780/RS880 PCI to PCI bridge (int
gfx) (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, medium devsel, latency 64, NUMA node 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: fe900000-feafffff
Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
Capabilities: <access denied>

00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI br
idge (PCIE port 3) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 19, NUMA node 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
Memory behind bridge: feb00000-febfffff
Capabilities: <access denied>
Kernel driver in use: pcieport
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI br
idge (PCIE port 5) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 18, NUMA node 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
I/O behind bridge: 0000e000-0000efff
Prefetchable memory behind bridge: 00000000fdf00000-00000000fdffffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (prog-if 01 [AHCI 1.0])
Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 22, NUMA node 0
I/O ports at c000 [size=8]
I/O ports at b000 [size=4]
I/O ports at a000 [size=8]
I/O ports at 9000 [size=4]
I/O ports at 8000 [size=16]
Memory at fe8ffc00 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ahci
Kernel modules: ahci

00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16, NUMA node 0
Memory at fe8fe000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci-pci

00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0 USB OHCI1 Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16, NUMA node 0
Memory at fe8fd000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci-pci

00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 USB EHCI Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 17, NUMA node 0
Memory at fe8ff800 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: ehci-pci

00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18, NUMA node 0
Memory at fe8fc000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci-pci

00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0 USB OHCI1 Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18, NUMA node 0
Memory at fe8fb000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci-pci

00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 USB EHCI Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 19, NUMA node 0
Memory at fe8ff400 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: ehci-pci

00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard
Flags: 66MHz, medium devsel, NUMA node 0
Capabilities: <access denied>
Kernel modules: i2c_piix4, sp5100_tco

00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller (prog-if 8a [ISA Compatibility mode controller, supports both channels switched to PCI native mode, supports bus mastering])
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 IDE Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16, NUMA node 0
I/O ports at 01f0 [size=8]
I/O ports at 03f4
I/O ports at 0170 [size=8]
I/O ports at 0374
I/O ports at ff00 [size=16]
Capabilities: <access denied>
Kernel driver in use: pata_atiixp
Kernel modules: pata_atiixp, pata_acpi
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard
Flags: bus master, slow devsel, latency 64, IRQ 16, NUMA node 0
Memory at fe8f4000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 LPC host controller
Flags: bus master, 66MHz, medium devsel, latency 0, NUMA node 0

00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (prog-if 01 [Subtractive decode])
Flags: bus master, 66MHz, medium devsel, latency 64, NUMA node 0
Bus: primary=00, secondary=04, subordinate=04, sec-latency=64

00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller (prog-if 10 [OHCI])
USB OHCI2 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 18, NUMA node 0
Memory at fe8fa000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci-pci

00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
Flags: fast devsel, NUMA node 0
Capabilities: <access denied>

00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
Flags: fast devsel, NUMA node 0

00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
Flags: fast devsel, NUMA node 0
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
Flags: fast devsel, NUMA node 0
Capabilities: <access denied>
Kernel driver in use: k10temp
Kernel modules: k10temp

00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
Flags: fast devsel, NUMA node 0

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. RS780L [Radeon 3000]
Flags: bus master, fast devsel, latency 0, IRQ 18, NUMA node 0
Memory at d0000000 (32-bit, prefetchable) [size=256M]
I/O ports at d000 [size=256]
Memory at feaf0000 (32-bit, non-prefetchable) [size=64K]
Memory at fe900000 (32-bit, non-prefetchable) [size=1M]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: radeon
Kernel modules: radeon

01:05.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RS780 HDMI Audio [Radeon 3000/3100 / HD 3200/3300]
Subsystem: ASUSTeK Computer Inc. RS780 HDMI Audio [Radeon 3000/3100 / HD 3200/3300]
Flags: bus master, fast devsel, latency 0, IRQ 19, NUMA node 0
Memory at feae8000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

02:00.0 USB controller: ASMedia Technology Inc. ASM1042A USB 3.0 Host Controller (prog-if 30 [XHCI])
Subsystem: ASUSTeK Computer Inc. ASM1042A USB 3.0 Host Controller
Flags: bus master, fast devsel, latency 0, IRQ 19, NUMA node 0
Memory at febf0000 (64-bit, non-prefetchable) [size=32K]
Capabilities: <access denied>
Kernel driver in use: xhci_hcd

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
Subsystem: ASUSTeK Computer Inc. P8 series motherboard
Flags: bus master, fast devsel, latency 0, IRQ 18, NUMA node 0
I/O ports at e800 [size=256]
Memory at fdfff000 (64-bit, prefetchable) [size=4K]
Memory at fdff8000 (64-bit, prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: r8169
Kernel modules: r8169
User avatar
Oxygen142
 
Posts: 4
Joined: Mon Sep 23, 2019 10:13 am

Re: Graphics lagging on Left for dead (working in win10)

Postby Oxygen142 » Mon Sep 23, 2019 5:55 pm

O sorry see you were asking for the VGA outputs only. :)
User avatar
Oxygen142
 
Posts: 4
Joined: Mon Sep 23, 2019 10:13 am

Re: Graphics lagging on Left for dead (working in win10)

Postby Swarfendor437 » Mon Sep 23, 2019 9:32 pm

This article may assist or hinder - if you have spare cash I would invest in a minimum of Nvidia GT630 card which is the lowest card that will run with the drivers that come with Zorin 15 or stretch the budget a wee bit more for a GT1030. Onboard graphics are never going to perform as well as a dedicated graphics card and use up some of your installed RAM to work at all! ;) :D
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 10419
Joined: Wed Sep 18, 2013 5:51 pm

Re: Graphics lagging on Left for dead (working in win10)

Postby Oxygen142 » Wed Sep 25, 2019 2:24 am

Hi

I agree this is not an ideal graphics card or let me say graphics to have but this is a secondary pc which is just used for internet browsing, WPS office and this one game.

With it not working on Zorin Os it either means I must test Linux mint os and or stick to Windows which I don't want to do. It's working 100% fine on windows and from my understanding Zorin we're suppose to use less resources so in effect run better.To buy a new graphics card just for this one game defeats the purpose.

Loading up the game etc is faster on Zorin. Everything is faster except in game mode which to me means driver related issues only. Or something I must set like hardware acceleration etc.

Btw, my main pc runs with a RX580 Graphics card but it's used for another purpose.
User avatar
Oxygen142
 
Posts: 4
Joined: Mon Sep 23, 2019 10:13 am

Re: Graphics lagging on Left for dead (working in win10)

Postby Aravisian » Wed Sep 25, 2019 3:24 am

Oxygen142 wrote:Hi

Running Left For Dead copied without Steam. Running it through Wine and using Zorin 15.

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. RS780L [Radeon 3000]
Flags: bus master, fast devsel, latency 0, IRQ 18, NUMA node 0
Memory at d0000000 (32-bit, prefetchable) [size=256M]
I/O ports at d000 [size=256]
Memory at feaf0000 (32-bit, non-prefetchable) [size=64K]
Memory at fe900000 (32-bit, non-prefetchable) [size=1M]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: radeon
Kernel modules: radeon


In a terminal, can you try:
Code: Select all
sudo add-apt-repository ppa:oibaf/graphics-drivers

Code: Select all
sudo apt-get update

Code: Select all
sudo apt update && sudo apt -y upgrade


Then open your preferred file manager with root privileges and navigate to: /etc/X11/xorg.conf
Open xorg,conf with a text editor and add:
Code: Select all
Section "Device"
    Identifier "AMDGPU"
    Driver "amdgpu"
    Option "AccelMethod" "glamor"
    Option "DRI" "3"
EndSection

Make sure you save before closing.
Once all that is done, please restart the machine by punching it in the face until it passes out, then throwing water on it.
No, ok wait... Flashbacks...
Restart however you restart the normal way.
It really should be running well on your machine.
User avatar
Aravisian
 
Posts: 716
Joined: Sun Dec 30, 2018 6:51 am

Re: Graphics lagging on Left for dead (working in win10)

Postby Swarfendor437 » Wed Sep 25, 2019 1:14 pm

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
I just love your posts Aravisian! :D
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 10419
Joined: Wed Sep 18, 2013 5:51 pm

Return to Help and Support

Who is online

Users browsing this forum: No registered users and 8 guests