[SOLVED] wireless internet connection

[SOLVED] wireless internet connection

Postby banjoman » Mon Sep 26, 2011 10:11 am

I am using Zorin 64 bit on a Toshiba Satellite Pro laptop and have a recurring problem when streaming radio programmes on BBC iPlayer. After a minute or so the streaming stops and often a message appears saying the content has stopped working (nothing like stating the obvious!).

Although the computer shows that I am still connected to my wireless internet connection, no web pages can be loaded. In order to re-establish the internet connection I have to disconnect and re-connect. This only seems to happen when streaming from BBC iPlayer, normal browsing, checking emails etc does not seem to break the internet connection.

The laptop also runs Windows 7, I do not have the same problem when operating under Windows, so the problem does not seem to be caused by the computer's hardware or the wireless connection or router itself.

Why does this happen under Zorin then?
User avatar
banjoman
 
Posts: 12
Joined: Thu Aug 18, 2011 11:47 am

Re: wireless internet connection

Postby Obsidian1723 » Mon Sep 26, 2011 1:27 pm

Next time that happens and it all just quits stream and no web pages load, pull up the terminal and do the following for us and then post the output information here plerase:

(CTL+c to stop these from running, so just post like 25 each)
1) ping 4.2.2.2
2) ping 8.8.8.8
3) ifconfig -a

We'll start there.
User avatar
Obsidian1723
 
Posts: 134
Joined: Sun Aug 28, 2011 9:37 pm
Location: Minnesota

Re: wireless internet connection

Postby banjoman » Mon Oct 31, 2011 3:03 pm

it has been a while since I used the laptop wirelessly, however the problem did occur the other day when I tried to stream an iPlayer radio programme

attached are two results of 'pinging' - they don't mean anything to me of course!!
User avatar
banjoman
 
Posts: 12
Joined: Thu Aug 18, 2011 11:47 am

Re: wireless internet connection

Postby banjoman » Mon Oct 31, 2011 3:10 pm

Tried to attach results, but .txt files don't seem to be allowed so will copy results within the post;

Test 1;
test for Zorin forum if and when streaming stops

(CTL+c to stop these from running, so just post like 25 each)
1) ping 4.2.2.2
2) ping 8.8.8.8
3) ifconfig -a

ping 4.2.2.2
PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.
64 bytes from 4.2.2.2: icmp_req=1 ttl=238 time=62.4 ms
64 bytes from 4.2.2.2: icmp_req=2 ttl=238 time=57.0 ms
64 bytes from 4.2.2.2: icmp_req=3 ttl=238 time=61.0 ms
64 bytes from 4.2.2.2: icmp_req=4 ttl=238 time=58.9 ms
64 bytes from 4.2.2.2: icmp_req=5 ttl=238 time=57.8 ms
64 bytes from 4.2.2.2: icmp_req=6 ttl=238 time=59.2 ms
64 bytes from 4.2.2.2: icmp_req=7 ttl=238 time=57.4 ms
64 bytes from 4.2.2.2: icmp_req=8 ttl=238 time=62.0 ms
64 bytes from 4.2.2.2: icmp_req=9 ttl=238 time=61.3 ms
64 bytes from 4.2.2.2: icmp_req=10 ttl=238 time=57.8 ms
64 bytes from 4.2.2.2: icmp_req=11 ttl=238 time=57.1 ms
64 bytes from 4.2.2.2: icmp_req=12 ttl=238 time=58.8 ms
64 bytes from 4.2.2.2: icmp_req=13 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=14 ttl=238 time=58.6 ms
64 bytes from 4.2.2.2: icmp_req=15 ttl=238 time=58.0 ms
64 bytes from 4.2.2.2: icmp_req=16 ttl=238 time=58.8 ms
64 bytes from 4.2.2.2: icmp_req=17 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=18 ttl=238 time=57.8 ms
64 bytes from 4.2.2.2: icmp_req=19 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=20 ttl=238 time=56.9 ms
--- 4.2.2.2 ping statistics ---
20 packets transmitted, 20 received, 0% packet loss, time 19026ms
rtt min/avg/max/mdev = 55.956/58.485/62.483/1.920 ms


ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=1 ttl=49 time=53.4 ms
64 bytes from 8.8.8.8: icmp_req=2 ttl=49 time=53.7 ms
64 bytes from 8.8.8.8: icmp_req=3 ttl=49 time=52.9 ms
64 bytes from 8.8.8.8: icmp_req=4 ttl=49 time=53.8 ms
64 bytes from 8.8.8.8: icmp_req=5 ttl=49 time=53.9 ms
64 bytes from 8.8.8.8: icmp_req=6 ttl=49 time=54.2 ms
64 bytes from 8.8.8.8: icmp_req=7 ttl=49 time=55.7 ms
64 bytes from 8.8.8.8: icmp_req=8 ttl=49 time=54.7 ms
64 bytes from 8.8.8.8: icmp_req=9 ttl=49 time=52.9 ms
64 bytes from 8.8.8.8: icmp_req=10 ttl=49 time=54.1 ms
64 bytes from 8.8.8.8: icmp_req=11 ttl=49 time=53.8 ms
64 bytes from 8.8.8.8: icmp_req=12 ttl=49 time=53.5 ms
64 bytes from 8.8.8.8: icmp_req=13 ttl=49 time=53.9 ms
64 bytes from 8.8.8.8: icmp_req=14 ttl=49 time=53.9 ms
64 bytes from 8.8.8.8: icmp_req=15 ttl=49 time=53.2 ms
64 bytes from 8.8.8.8: icmp_req=16 ttl=49 time=54.2 ms
64 bytes from 8.8.8.8: icmp_req=17 ttl=49 time=52.8 ms
64 bytes from 8.8.8.8: icmp_req=18 ttl=49 time=53.9 ms
64 bytes from 8.8.8.8: icmp_req=19 ttl=49 time=52.9 ms
64 bytes from 8.8.8.8: icmp_req=20 ttl=49 time=54.2 ms
64 bytes from 8.8.8.8: icmp_req=21 ttl=49 time=52.3 ms
64 bytes from 8.8.8.8: icmp_req=22 ttl=49 time=53.2 ms
--- 8.8.8.8 ping statistics ---
22 packets transmitted, 22 received, 0% packet loss, time 21028ms
rtt min/avg/max/mdev = 52.364/53.731/55.764/0.766 ms

ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:xx:xx:xx:xx:xx
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:44 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5376 (5.3 KB) TX bytes:5376 (5.3 KB)

wlan0 Link encap:Ethernet HWaddr 70:xx:xx:xx:xx:xx
inet addr:192.168.1.72 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::721a:4ff:fec3:939/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:28136 errors:0 dropped:0 overruns:0 frame:0
TX packets:22151 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:35776405 (35.7 MB) TX bytes:2174445 (2.1 MB)
Interrupt:19 Memory:ffffc90010578000-ffffc90010578100

Test 2
test for Zorin forum if and when streaming stops

(CTL+c to stop these from running, so just post like 25 each)
1) ping 4.2.2.2
2) ping 8.8.8.8
3) ifconfig -a

ping 4.2.2.2
PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.
64 bytes from 4.2.2.2: icmp_req=3 ttl=238 time=56.6 ms
64 bytes from 4.2.2.2: icmp_req=4 ttl=238 time=56.0 ms
64 bytes from 4.2.2.2: icmp_req=5 ttl=238 time=55.0 ms
64 bytes from 4.2.2.2: icmp_req=6 ttl=238 time=55.6 ms
64 bytes from 4.2.2.2: icmp_req=7 ttl=238 time=56.1 ms
64 bytes from 4.2.2.2: icmp_req=8 ttl=238 time=55.0 ms
64 bytes from 4.2.2.2: icmp_req=9 ttl=238 time=59.8 ms
64 bytes from 4.2.2.2: icmp_req=10 ttl=238 time=56.1 ms
64 bytes from 4.2.2.2: icmp_req=11 ttl=238 time=55.7 ms
64 bytes from 4.2.2.2: icmp_req=12 ttl=238 time=57.8 ms
64 bytes from 4.2.2.2: icmp_req=13 ttl=238 time=56.4 ms
64 bytes from 4.2.2.2: icmp_req=14 ttl=238 time=55.8 ms
64 bytes from 4.2.2.2: icmp_req=15 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=16 ttl=238 time=60.9 ms
64 bytes from 4.2.2.2: icmp_req=17 ttl=238 time=55.2 ms
64 bytes from 4.2.2.2: icmp_req=18 ttl=238 time=62.7 ms
64 bytes from 4.2.2.2: icmp_req=19 ttl=238 time=55.2 ms
64 bytes from 4.2.2.2: icmp_req=20 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=21 ttl=238 time=56.2 ms
64 bytes from 4.2.2.2: icmp_req=22 ttl=238 time=55.4 ms
64 bytes from 4.2.2.2: icmp_req=23 ttl=238 time=54.9 ms
64 bytes from 4.2.2.2: icmp_req=24 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=25 ttl=238 time=55.3 ms
64 bytes from 4.2.2.2: icmp_req=26 ttl=238 time=59.4 ms
64 bytes from 4.2.2.2: icmp_req=27 ttl=238 time=60.6 ms
64 bytes from 4.2.2.2: icmp_req=28 ttl=238 time=56.1 ms
64 bytes from 4.2.2.2: icmp_req=29 ttl=238 time=54.7 ms
64 bytes from 4.2.2.2: icmp_req=30 ttl=238 time=55.6 ms
64 bytes from 4.2.2.2: icmp_req=31 ttl=238 time=56.0 ms
64 bytes from 4.2.2.2: icmp_req=32 ttl=238 time=54.7 ms
64 bytes from 4.2.2.2: icmp_req=33 ttl=238 time=56.0 ms
64 bytes from 4.2.2.2: icmp_req=34 ttl=238 time=60.8 ms
64 bytes from 4.2.2.2: icmp_req=35 ttl=238 time=55.8 ms
64 bytes from 4.2.2.2: icmp_req=36 ttl=238 time=57.7 ms
64 bytes from 4.2.2.2: icmp_req=37 ttl=238 time=54.9 ms
64 bytes from 4.2.2.2: icmp_req=38 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=39 ttl=238 time=55.2 ms
64 bytes from 4.2.2.2: icmp_req=40 ttl=238 time=55.0 ms
64 bytes from 4.2.2.2: icmp_req=41 ttl=238 time=55.1 ms
64 bytes from 4.2.2.2: icmp_req=42 ttl=238 time=55.6 ms
64 bytes from 4.2.2.2: icmp_req=43 ttl=238 time=59.2 ms
64 bytes from 4.2.2.2: icmp_req=44 ttl=238 time=54.5 ms
64 bytes from 4.2.2.2: icmp_req=45 ttl=238 time=55.9 ms
64 bytes from 4.2.2.2: icmp_req=46 ttl=238 time=57.9 ms
64 bytes from 4.2.2.2: icmp_req=47 ttl=238 time=55.0 ms
64 bytes from 4.2.2.2: icmp_req=48 ttl=238 time=55.4 ms
64 bytes from 4.2.2.2: icmp_req=49 ttl=238 time=55.1 ms
64 bytes from 4.2.2.2: icmp_req=50 ttl=238 time=54.9 ms
64 bytes from 4.2.2.2: icmp_req=51 ttl=238 time=56.2 ms
64 bytes from 4.2.2.2: icmp_req=52 ttl=238 time=54.6 ms
64 bytes from 4.2.2.2: icmp_req=53 ttl=238 time=56.9 ms
64 bytes from 4.2.2.2: icmp_req=54 ttl=238 time=58.6 ms
64 bytes from 4.2.2.2: icmp_req=55 ttl=238 time=56.3 ms
64 bytes from 4.2.2.2: icmp_req=56 ttl=238 time=55.5 ms
^C
--- 4.2.2.2 ping statistics ---
56 packets transmitted, 54 received, 3% packet loss, time 55068ms
rtt min/avg/max/mdev = 54.542/56.426/62.798/1.855 ms

ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=1 ttl=49 time=53.4 ms
64 bytes from 8.8.8.8: icmp_req=2 ttl=49 time=54.8 ms
64 bytes from 8.8.8.8: icmp_req=3 ttl=49 time=52.9 ms
64 bytes from 8.8.8.8: icmp_req=4 ttl=49 time=52.5 ms
64 bytes from 8.8.8.8: icmp_req=5 ttl=49 time=57.4 ms
64 bytes from 8.8.8.8: icmp_req=6 ttl=49 time=52.8 ms
64 bytes from 8.8.8.8: icmp_req=7 ttl=49 time=53.7 ms
64 bytes from 8.8.8.8: icmp_req=8 ttl=49 time=54.0 ms
64 bytes from 8.8.8.8: icmp_req=9 ttl=49 time=53.0 ms
64 bytes from 8.8.8.8: icmp_req=10 ttl=49 time=53.8 ms
64 bytes from 8.8.8.8: icmp_req=11 ttl=49 time=53.7 ms
64 bytes from 8.8.8.8: icmp_req=12 ttl=49 time=52.9 ms
64 bytes from 8.8.8.8: icmp_req=13 ttl=49 time=53.4 ms
64 bytes from 8.8.8.8: icmp_req=14 ttl=49 time=56.4 ms
64 bytes from 8.8.8.8: icmp_req=15 ttl=49 time=53.2 ms
64 bytes from 8.8.8.8: icmp_req=16 ttl=49 time=53.8 ms
64 bytes from 8.8.8.8: icmp_req=17 ttl=49 time=53.7 ms
64 bytes from 8.8.8.8: icmp_req=18 ttl=49 time=52.9 ms
64 bytes from 8.8.8.8: icmp_req=19 ttl=49 time=52.4 ms
64 bytes from 8.8.8.8: icmp_req=20 ttl=49 time=52.8 ms
64 bytes from 8.8.8.8: icmp_req=21 ttl=49 time=52.9 ms
^C
--- 8.8.8.8 ping statistics ---
21 packets transmitted, 21 received, 0% packet loss, time 20026ms
rtt min/avg/max/mdev = 52.497/53.688/57.416/1.194 ms

ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:xx:xx:xx:xx:xx
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:44 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:216 errors:0 dropped:0 overruns:0 frame:0
TX packets:216 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:16972 (16.9 KB) TX bytes:16972 (16.9 KB)

wlan0 Link encap:Ethernet HWaddr 70:xx:xx:xx:xx:xx
inet addr:192.168.1.72 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::721a:4ff:fec3:939/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:33232 errors:0 dropped:0 overruns:0 frame:0
TX packets:26879 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:40837323 (40.8 MB) TX bytes:2925121 (2.9 MB)
Interrupt:19 Memory:ffffc90010578000-ffffc90010578100
User avatar
banjoman
 
Posts: 12
Joined: Thu Aug 18, 2011 11:47 am

Re: wireless internet connection

Postby killeriq » Mon Nov 21, 2011 12:23 am

Hello,

I have issue that the original Network Manager, that i cant search for WIFI networks, even when i set up all the things as u mention...Even Zorin should be user friendly but this WIFI network setup just sux...

So ive tried http://projects.gnome.org/NetworkManager/ ive install the package restarted the OS and no network at all :( (network icon is gone ) i cant even install the NM-applet cos the OS is missing some libaries and i cant use Synaptic

Other try i did try NetworkManager and WICD seems that it got messed up as well :( NetworkManager is just trying to connect and then is disconnect ...again and again :(

Any way how i cant restore original Network or i just need to do fresh install?
Is there any easy way how to search fot available WIFI networks? or i just need to use 3rd party appz?

Thanks!
User avatar
killeriq
 
Posts: 16
Joined: Sun Nov 20, 2011 11:32 pm

Re: wireless internet connection

Postby killeriq » Mon Nov 21, 2011 2:04 am

Hello,

I have issue that the original Network Manager, that i cant search for WIFI networks, even when i set up all the things as u mention...Even Zorin should be user friendly but this WIFI network setup just sux...

So ive tried http://projects.gnome.org/NetworkManager/ ive install the package restarted the OS and no network at all :( (network icon is gone ) i cant even install the NM-applet cos the OS is missing some libaries and i cant use Synaptic

Other try i did try NetworkManager and WICD seems that it got messed up as well :( NetworkManager is just trying to connect and then is disconnect ...again and again :(

Any way how i cant restore original Network or i just need to do fresh install?
Is there any easy way how to search fot available WIFI networks? or i just need to use 3rd party appz?

Thanks!
User avatar
killeriq
 
Posts: 16
Joined: Sun Nov 20, 2011 11:32 pm

Re: wireless internet connection

Postby killeriq » Wed Nov 23, 2011 12:02 pm

after 2 days of googling, reinstalling whole system for the 4rd time i have an solution! :)

do: rfkill list

and something like this will show up:
0: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: phy0: Wirless LAN
Soft blocked: no
Hard blocked: no

Try blacklisting the acer-wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf
add blacklist acer_wmi as a new line at the bottom of this file.

then reboot.

edit:

The acer-wmi kernel module enables you to control the following:

the wireless LAN card radio
inbuilt Bluetooth adapter
inbuilt 3G card
mail LED of your laptop
brightness of the LCD panel
With regards to wireless, all acer-wmi does is enable the radio on the card. It is not responsible for the wireless LED - once the radio is enabled, this is down to the wireless driver for your card.

However for some acer laptop models - there is a conflict between the Acer firmware and the kernel implementation. This is why you need to blacklist.

Found it over here:
http://askubuntu.com/questions/67437/ho ... ros-ar9285
http://askubuntu.com/questions/65779/ho ... rd-working
http://askubuntu.com/questions/57360/wu ... 7367#57367
User avatar
killeriq
 
Posts: 16
Joined: Sun Nov 20, 2011 11:32 pm

Return to Help and Support

Who is online

Users browsing this forum: Google [Bot] and 6 guests