Ubuntu Language Settings How-To & Reset Locales Manually

Ubuntu Language Settings How-To & Reset Locales Manually

Postby Wolfman » Mon Mar 12, 2012 2:39 pm

Hi,

Go to the Control Center and start "Language Support" then click on add/remove languages, make sure that the only language in the list is the one you want, example: English. Take the tick out of any unwanted languages and leave only one tick in English!!.

If you are having problems with language on your PC; install the package "localepurge" to rid your PC of all unwanted language packages!!. Select which packages you wish to keep during the installation of the package (localepurge), you need to make sure that all the different packages for the same language are marked!!. (A good example is French as there is Swiss French; Belgium French and French!)

I suggest that the default repository for your downloads; should be "Main".

See also:

http://askubuntu.com/questions/289190/h ... m-language

http://www.howtogeek.com/howto/17528/ch ... in-ubuntu/

This is my own guide using German as my example.

open language support in the Systems Settings menu and click on "Install/Remove Languages" then put a tick in the box for German, at the same time, take out the tick for the English language:
Workspace 1_037.png


Click on "Apply Changes" and let it do its thing, you will be asked for your password:
Workspace 1_038.png


Now you will see in the main window that "Deutsch" is showing faintly in the list, we need to left mouse click and hold it down and push "Deutsch" up to the top of the list, once you have pushed it to the top; click on "Apply System Wide", now go to "Regional Formats and select Deutsch (Deutschland) and "Apply system Wide", then close the window and restart your PC:
Language Support_039.png


Language Support_040.png


Language Support_041.png


When you restart your PC, you will be asked whether you want to change the names of your folders to the new default language, say yes and then all your system folders will change to the newly installed language, in this case "German":
Namenloses Fenster_042.png



Reset Ubuntu Locales Manually:

Make sure that you have installed your desired country locale files before you start doing the following!.

To manually reset your system locale should the above not have worked for you, you need to make yourself "root", open a terminal with Ctrl + Alt + t and enter the following command:

Code: Select all
gksudo nautilus


Enter your password and navigate through your home folder: Computer (or File System) > Etc > Default > Locale

You will now have a file that looks like this, I will be using German for my example, you need to replace the appropriate lines (Lang & Language) with your desired country locale!.

LANG="en_GB.UTF-8"
LANGUAGE="en_GB:en"

LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"

In my example, you need to change the top two lines to look like this, edit/replace "en_EN" with "de_DE":

LANG="de_DE.UTF-8"
LANGUAGE="de_DE:de"

LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"

(All the lines beginning with "LC" are still set to en_GB, which is what I want, you would need to make sure that all yours are set to "de_DE" as per my example language!.)

Once you have made your changes, click on "File" > "Save" close Gedit and restart your PC, your system should restart in the desired language and you will be asked to change the folder names which you should do!.

Namenloses Fenster_042.png


See also:

https://help.ubuntu.com/community/Locale

http://askubuntu.com/questions/33025/lo ... reset-them

If your language still doesn't change; you need to open: > For Zorin OS 6: System Settings > Hardware > Keyboard > Layout Settings > Formats. For Zorin OS 9: System Settings > Hardware > Keyboard > Text Entry and select your language from the list and restart your PC:

Zorin 9:
Text Entry_026.jpg


Zorin 6:
Region & Language_022.jpg


If you only want extra language support but still want your system in English, open Synaptic and type "libreoffice french" or whatever language packages you need and select and install the results that show up. This will add language support for Libreoffice so you can type in languages other than English!.


Keyboard input method system

For languages with complicated symbols like Chinese/Vietnamese/Japanese etc, it is recommended you set "Keyboard input method system" to "IBus".
Language Support_052.jpg


See also:

https://help.ubuntu.com/community/Locale

http://askubuntu.com/questions/33025/lo ... reset-them


Adding more keyboard language support:

see this link:

http://www.howtogeek.com/howto/17508/ad ... to-ubuntu/

See this link also about adding extra packages for mainly Asian languages:

https://help.ubuntu.com/stable/ubuntu-h ... youts.html

Hope it helps.
Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm

Re: [STICKY] Ubuntu Language Settings How-To

Postby cloutiy » Thu Sep 27, 2012 4:32 pm

Very helpful thank you!
User avatar
cloutiy
 
Posts: 3
Joined: Thu Sep 27, 2012 2:22 am

Re: [STICKY] Ubuntu Language Settings How-To

Postby mtpmoni » Mon Oct 01, 2012 2:27 pm

Hello,

the howto do not complety function for zorin os 6 withe the newest updates.

I can only activate the installed alternative language in the user preferences.
First for the one user and the systemwide.

the menu language is still in english not in the wanted language.
in my case, the altenative language are german (de_DE@euro)

can i change the desktop-menu in german?

mtpmoni
User avatar
mtpmoni
 
Posts: 1
Joined: Mon Oct 01, 2012 2:18 pm

Re: [STICKY] Ubuntu Language Settings How-To

Postby Wolfman » Tue Oct 02, 2012 2:52 pm

mtpmoni wrote:Hello,

the howto do not complety function for zorin os 6 withe the newest updates.

I can only activate the installed alternative language in the user preferences.
First for the one user and the systemwide.

the menu language is still in english not in the wanted language.
in my case, the altenative language are german (de_DE@euro)

can i change the desktop-menu in german?

mtpmoni

Hi and Herzlich willkommen,

further to Swarf's suggestions which are basically the same as mine, you should check your software download sources and change the download location:

viewtopic.php?f=6&t=2247

Choose a different server and/or a different country, there are problems with Ubuntu updates at the moment, see also:

viewtopic.php?f=6&t=3009

Eine Lösung auf Deutsch:

http://wiki.ubuntuusers.de/Spracheinste ... stellungen

http://forum.ubuntuusers.de/topic/sprac ... st-4808222

Regards Wolfman :D
Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm

Re: [STICKY] Ubuntu Language Settings How-To

Postby Wolfman » Wed Oct 16, 2013 10:50 am

Guide updated with manual Gedit changes!.

Regards Wolfman :D
Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm

Re: Ubuntu Language Settings How-To & Reset Locales Manuall

Postby stgermain » Mon Nov 25, 2013 7:27 pm

Hello,

I like to have Zorin in Dutch,so I followed the above tut. However, I always get an error: Failed to download package files - in the details I noticed a 404 error too. I couldn't copy the whole error, sorry.

How do I resolve this? Is there a way via the terminal? And how?

Thanks
User avatar
stgermain
 
Posts: 1
Joined: Mon Nov 25, 2013 7:19 pm

Re: Ubuntu Language Settings How-To & Reset Locales Manuall

Postby Swarfendor437 » Thu Nov 28, 2013 2:02 pm

stgermain wrote:Hello,

I like to have Zorin in Dutch,so I followed the above tut. However, I always get an error: Failed to download package files - in the details I noticed a 404 error too. I couldn't copy the whole error, sorry.

How do I resolve this? Is there a way via the terminal? And how?

Thanks


Try changing you update settings to 'Main Server' - keep us posted! :D
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 9981
Joined: Wed Sep 18, 2013 5:51 pm

Re: Ubuntu Language Settings How-To & Reset Locales Manuall

Postby Wolfman » Fri Nov 29, 2013 8:34 am

Hi,

change your sources download selection to another server, see update guide on how to do that:

viewtopic.php?f=6&t=2247

Then try updating again.

Regards Wolfman :D
Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm

Re: Ubuntu Language Settings How-To & Reset Locales Manuall

Postby LEEWU » Wed Apr 02, 2014 10:14 am

I'm Vietnamese and in my country, Linux User must have install ibus and ibus-unikey for type my language with Unicode. I've just install ZorinOS core 8, it work perfectly with Unicode . I'm already installed ibus and ibus-unikey package so I cant found Ibus icon to active typing with my language. Help me how to active ibus in ZorinOS 8. Thanks and regard
User avatar
LEEWU
 
Posts: 1
Joined: Wed Apr 02, 2014 10:05 am

Re: Ubuntu Language Settings How-To & Reset Locales Manuall

Postby Wolfman » Fri Apr 04, 2014 9:42 am

LEEWU wrote:I'm Vietnamese and in my country, Linux User must have install ibus and ibus-unikey for type my language with Unicode. I've just install ZorinOS core 8, it work perfectly with Unicode . I'm already installed ibus and ibus-unikey package so I cant found Ibus icon to active typing with my language. Help me how to active ibus in ZorinOS 8. Thanks and regard

Hi Leewu,

open language support > "Keyboard input method system" and change "None" to "Ibus", simple as that:

Language Support_001.jpg


Regards Wolfman :D
Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm
Next

Return to How-tos and Tutorials

Who is online

Users browsing this forum: gho1 and 1 guest