Stop the screen from blanking in Ubuntu

Stop the screen from blanking in Ubuntu

Postby Wolfman » Sat Feb 08, 2014 7:47 pm

Hi all,

like the title says, if your screen blanks after a few minutes despite disabling screensaver etc, copy and paste the following command:

Code: Select all
xset -dpms s off s noblank s 0 0 s noexpose


Open "Startup Applications" > "Add" then add the command to the command line and give it a name then save it and restart your PC.

Edit Startup Program_003.jpeg
Edit Startup Program_003.jpeg (9.9 KiB) Viewed 1937 times


Startup Applications Preferences_002.png
Startup Applications Preferences_002.png (61.86 KiB) Viewed 1937 times


Also open Dconf Editor and take out the tick:

Dconf Editor > Org > Gnome > Desktop > Screensaver > idle-activation-enabled

Also, you can paste this command in a terminal then open "Startup Applications" which will now show all startup entries if you are still having problems with screensaver, take out the tick in the box if it is indeed there.

Code: Select all
sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop


To test whether screensaver is not running after doing the above and a restart, open a terminal and type "xset -q" and check that screensaver is disabled.

Code: Select all
xset -q


Regards Wolfman :D
Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm

Return to How-tos and Tutorials

Who is online

Users browsing this forum: No registered users and 3 guests