How to get your Canon Scanner/All-in-One working!

How to get your Canon Scanner/All-in-One working!

Postby Swarfendor437 » Sat Aug 08, 2015 5:22 pm

Hi folks, WARNING THIS MAY NOT WORK FOR YOU BUT DO GIVE IT A TRY!

OK, I reported that I could not get Canon MG7550 working with Simple Scan but could get it working with VueScan demo - the paid version is quite pricey i.e. the Pro one which most people would want to use.

However there is a simple interface that Canon uses - I decided to take a look with Sofware Centre after installing the driver package appropriate for this OS (Zorin 10 32-bit) - and Software Centre gave me the clue I was looking for! :D

38.jpg


OK, the software that gets installed is 'scangearmp2' - enter this in a terminal window and the interface shows up - the downside is that there is no preview of what you are scanning but it does work! :D

Ok, so you don't want to have to keep launching the terminal every time, so if you can't edit your menu, install 'alacarte' - then you will be able to!

Right-click your 'Z' and select 'Edit Menus'.



Then select the 'Add Item' button on the right and create an icon that will launch as shown below:

35.png


I then double-clicked the default icon (platform on a spring) to search for a different icon - you need to browse 'computer' from left pane, then this path:

usr | share | icons | Zorin - the select 'devices' then 'scanner-symbolic.svg' :D

Be sure to add your item in the Graphics sub menu!

24.jpg
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 10003
Joined: Wed Sep 18, 2013 5:51 pm

Return to How-tos and Tutorials

Who is online

Users browsing this forum: No registered users and 2 guests