[STICKY] Get Wireless Connection working on Alienware Laptop

[STICKY] Get Wireless Connection working on Alienware Laptop

Postby Fringe Wizard » Sun Aug 16, 2015 1:47 am

I've been trying out various linux OS, installing them to my 128 GB thumbstick drive, and running them on my alienware laptop. None of them could detect the wireless card by default which on Alienware is Killer 1525 802.11ac 2x2 WiFi and Bluetooth 4.1

Here is the fix for that I found... first download: http://blog.hyperexpert.com/wp-content/ ... .0_all.deb and put that on the desktop.

Do ctrl + alt + t to open up Terminal.

Then type this command
Code: Select all
sudo dpkg --install /home/fringe/Desktop/ath10k-dkms_1.0_all.deb
and hit enter.

Except change fringe to your account name.

I would hope that in the future Zorin OS doesn't have this problem when you are installing it new on an alienware computer. I had to connect an ethernet cable to fix this issue.

Sorry if this is in the wrong sub-forum I am not sure where to put this. I have also a request that you make the power indicator capable of showing the power left in wireless mouse and keyboard just like on Linux Mint.

>inb4 someone mocks me for having an alienware laptop or for having one and installing Linux on it

I hate Windows and I only use Gimp and Blender and run Unity 3D in Wine and I play my games just fine on Linux.

If anyone knows how to install a persistent Linux OS onto a thumbstick drive so you can have your OS, update your OS, and have all your files all on the same thumbstick drive you can take anywhere please tell me btw. I tried various versions of Puppy and none of them worked for me.
User avatar
Fringe Wizard
 
Posts: 4
Joined: Sun Aug 16, 2015 1:20 am

Re: Get Wireless Connection working on Alienware Laptop

Postby Wolfman » Sun Aug 16, 2015 8:11 am

Regards Wolfman :D

Kindness is something the blind can see and the deaf can hear :)

Preparation and planning prevent poor performance! :)

Free Ubuntu User Manual: https://ubuntu-manual.org/
User avatar
Wolfman
 
Posts: 7611
Joined: Sat Jul 02, 2011 1:03 pm

Re: [STICKY] Get Wireless Connection working on Alienware La

Postby Swarfendor437 » Sun Aug 16, 2015 2:16 pm

Hi, I did not want your [STICKY] to be too far down the list in this section so have made it a [STICKY] - it should now be near the top! ;) :D
https://vimeo.com/user15592214
https://trisquel.info/
https://www.opendesktop.org/member/257685/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 9986
Joined: Wed Sep 18, 2013 5:51 pm

Return to How-tos and Tutorials

Who is online

Users browsing this forum: No registered users and 4 guests