The Super Key

The Super Key

Postby Deacon » Mon Dec 31, 2012 9:17 pm

Ok. Here's a list of things I did to get the Super Key bound to the menu, none of which have been successful. That said, I feel like I've almost got it. If we put our heads together there has to be a way to solve. The last response on anything Gnomenu related basically got referred... to the Zorin team.

In other words, I think Gnomenu is kind of being seen as owned by Zorin OS people now. So let's beat it up and make it work!

Using Zorin 6.1 Core 32-Bit

Process of Elimination

1. Tried xmodmap.

Code: Select all
xmodmap -e "remove mod4 = Super_L"


This did not work. Reverted it with

Code: Select all
xmodmap -e "add mod4 = Super_L"


2. Checked Keyboard Settings.

Default settings were found to have two super commands. I removed them. I don't like what they do so I don't want them back. No effect.

3. Attempted "Super", "Super L", "Super L" (shift space), "Mod4" and "<Super>" in the binding section of Preferences panel.

No dice.

4. Ran Compiz Configuration Settings Manager.

Keybindings are enabled, unsure of what command to use to activate the Super Key.

5. Not tried yet: Updating Python version in a line of gnomenu's code.

For the idea, it's here. I have not found that file yet where the change can be made. Python 2.7.3 is installed.
https://answers.launchpad.net/gnomenu/+question/52610

Anyone else want to join in with what hasn't worked, so we can eliminate the issue and figure out what does? My guess is, based on what I've learned, that something is either overriding Gnomenu's keybind or (5) it isn't actually working right now.
Zorin OS saved the family business: currently using various systems w/ main system: Puppy. Name= Dcn Joseph

If you think a bunch of people are crazy, and the crazies are the only ones who get what you're saying, you might be one of those crazies. ;)
User avatar
Deacon
 
Posts: 72
Joined: Sun Dec 23, 2012 6:51 pm

Return to Brainstorm

Who is online

Users browsing this forum: No registered users and 1 guest