[SOLVED] Boot directly into Zorin

[SOLVED] Boot directly into Zorin

Postby kcaps » Thu Jan 09, 2020 11:59 am

I have just fresh installed Zorin, and I'm trying to set it up so it boots directly into the os without getting stuck on this screen:
Image/https://imgur.com/82KHfRr

After following various guides on stackoverflow, askubuntu, and probably elsewhere, my /etc/default/grub looks like this:
Code: Select all
GRUB_DEFAULT="Zorin"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_HIDDEN_TIMEOUT="0"
GRUB_TIMEOUT="0"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX="noprompt"
GRUB_DISABLE_OS_PROBER="true"
GRUB_HIDDEN_TIMEOUT_QUIET="false"

GRUB_THEME="/usr/share/grub/themes/zorin/theme.txt"
GRUB_SAVEDEFAULT="false"
export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="magenta/black"


Of course I also ran sudo update-grub.
But when I boot up it always goes to the attached screen first.

My specs are as follows:
ASUS ZenBook Flip S UX370UA
16Gb ram
Only Zorin is installed, used lvm with automatic installation

I'd appreciate any help!
Last edited by kcaps on Tue Jan 14, 2020 10:59 pm, edited 1 time in total.
User avatar
kcaps
 
Posts: 14
Joined: Thu Jan 09, 2020 8:05 am

Re: Boot directly into Zorin

Postby Swarfendor437 » Thu Jan 09, 2020 2:01 pm

My advice is don't login to Zorin automatically - you will have issues updating when it asks for your non-existent password to elevate you to 'root' (administrator). I'm surprised that you get GRUB showing - mine only shows because I have more than one GNU/Linux on 2 other drives. Normally you would not see GRUB when Zorin is the only install so I don't know why you get that 'static' option screen. Normally it would be 10 second progress bar across the top before the glowing Zorin logo appears before eventual login screen. ;) :D
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11268
Joined: Wed Sep 18, 2013 5:51 pm

Re: Boot directly into Zorin

Postby Aravisian » Thu Jan 09, 2020 4:17 pm

Swarfendor437 wrote:My advice is don't login to Zorin automatically - you will have issues updating when it asks for your non-existent password to elevate you to 'root' (administrator). I'm surprised that you get GRUB showing - mine only shows because I have more than one GNU/Linux on 2 other drives. Normally you would not see GRUB when Zorin is the only install so I don't know why you get that 'static' option screen. Normally it would be 10 second progress bar across the top before the glowing Zorin logo appears before eventual login screen. ;) :D


Strong agreement.

kcaps wrote:I have just fresh installed Zorin, and I'm trying to set it up so it boots directly into the os without getting stuck on this screen:

After following various guides on stackoverflow, askubuntu, and probably elsewhere, my /etc/default/grub looks like this:

I notice that you have several duplicate entries. Some counteract each other.
Could you try adjusting your grub to look like the following:
Code: Select all
GRUB_DEFAULT="Zorin"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_OS_PROBER="true"
GRUB_THEME="/usr/share/grub/themes/zorin/theme.txt"
export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="magenta/black"

What you might add to it is:
Code: Select all
GRUB_DISABLE_RECOVERY="true"

I question whether you really need the GRUB_DISABLE_OS_PROBER="true"---Only you would know that from using your machine. But I might suggest that you disable that (Or comment it out with a hashtag) and test starting up without it. If you experience lengthy boot up times, you may go back in and enable it.
User avatar
Aravisian
 
Posts: 1527
Joined: Sun Dec 30, 2018 6:51 am

Re: Boot directly into Zorin

Postby kcaps » Thu Jan 09, 2020 7:50 pm

Swarfendor437 wrote:My advice is don't login to Zorin automatically

I don't. I have a password and I have to use it to login and run sudo.

Swarfendor437 wrote:I'm surprised that you get GRUB showing - mine only shows because I have more than one GNU/Linux on 2 other drives. Normally you would not see GRUB when Zorin is the only install so I don't know why you get that 'static' option screen.

I had installed some other distros before Zorin, but even if they had left "leftovers" after the fresh install, shouldn't disabling the os prober ignore them anyway?

Swarfendor437 wrote:Normally it would be 10 second progress bar across the top before the glowing Zorin logo appears before eventual login screen. ;) :D

I do get the progress bar. I guess I didn't take the picture properly.

Aravisian wrote:I notice that you have several duplicate entries. Some counteract each other.


I will try your suggested edits. The reason I had disabled the os prober is because I thought if grub doesn't bother searching for alternate os'es it might boot Zorin right away.
User avatar
kcaps
 
Posts: 14
Joined: Thu Jan 09, 2020 8:05 am

Re: Boot directly into Zorin

Postby Aravisian » Thu Jan 09, 2020 7:55 pm

kcaps wrote:
Swarfendor437 wrote:My advice is don't login to Zorin automatically

I don't. I have a password and I have to use it to login and run sudo.

Swarfendor437 wrote:I'm surprised that you get GRUB showing - mine only shows because I have more than one GNU/Linux on 2 other drives. Normally you would not see GRUB when Zorin is the only install so I don't know why you get that 'static' option screen.

I had installed some other distros before Zorin, but even if they had left "leftovers" after the fresh install, shouldn't disabling the os prober ignore them anyway?

Swarfendor437 wrote:Normally it would be 10 second progress bar across the top before the glowing Zorin logo appears before eventual login screen. ;) :D

I do get the progress bar. I guess I didn't take the picture properly.

Aravisian wrote:I notice that you have several duplicate entries. Some counteract each other.


I will try your suggested edits. The reason I had disabled the os prober is because I thought if grub doesn't bother searching for alternate os'es it might boot Zorin right away.

This is an odd case. Yes, a fresh install should have wiped out any "leftovers" from the previous O.S.' installed.
How long has it been since you installed Zorin?
User avatar
Aravisian
 
Posts: 1527
Joined: Sun Dec 30, 2018 6:51 am

Re: Boot directly into Zorin

Postby Swarfendor437 » Fri Jan 10, 2020 12:54 am

To ensure a clean install, run Gparted, even on it's own CD, and delete every partition (you need to unmount swap before you can remove it) and get to the point where you have an empty drive. Then start afresh by adding '/', then create an extended partition - add 'swap' at the end, double the size of your Physical RAM. The space left in front of swap on the extended partition mark as '/home' - if you have an EFI enabled BIOS, right at the start of the drive you will need a 35 Mb ESP (EFI) partition,
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11268
Joined: Wed Sep 18, 2013 5:51 pm

Re: Boot directly into Zorin

Postby kcaps » Tue Jan 14, 2020 7:47 pm

Aravisian wrote:This is an odd case. Yes, a fresh install should have wiped out any "leftovers" from the previous O.S.' installed.
How long has it been since you installed Zorin?

Around a week.

Swarfendor437 wrote:To ensure a clean install, run Gparted, even on it's own CD, and delete every partition (you need to unmount swap before you can remove it) and get to the point where you have an empty drive. Then start afresh by adding '/', then create an extended partition - add 'swap' at the end, double the size of your Physical RAM. The space left in front of swap on the extended partition mark as '/home' - if you have an EFI enabled BIOS, right at the start of the drive you will need a 35 Mb ESP (EFI) partition,

I had only used elementary os before(no lvm), this is a new laptop. When I installed Zorin I picked "Erase drive" and also used LVM.
Do I have to wipe everything and reinstall? it seems overkill..

Aravisian wrote:I question whether you really need the GRUB_DISABLE_OS_PROBER="true"---Only you would know that from using your machine. But I might suggest that you disable that (Or comment it out with a hashtag) and test starting up without it. If you experience lengthy boot up times, you may go back in and enable it.

I tried them, no success.

I also tried doing:
Code: Select all
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

and then rebooting twice , for grub to save the selection. No dice.
It can't be impossible to get this. What else can I try?
User avatar
kcaps
 
Posts: 14
Joined: Thu Jan 09, 2020 8:05 am

Re: Boot directly into Zorin

Postby Aravisian » Tue Jan 14, 2020 7:56 pm

kcaps wrote: it seems overkill..

Honestly, I would do it. If you have only been running it about a week, then you probably have not really gotten settled in, yet. I would back up Home Folder and wipe and reload.
User avatar
Aravisian
 
Posts: 1527
Joined: Sun Dec 30, 2018 6:51 am

Re: Boot directly into Zorin

Postby kcaps » Tue Jan 14, 2020 10:08 pm

I had a bad experience with installing a new distro on a drive with LVM installed (Installed Zorin on another computer), i had to spend hours on google yesterday when I wiped the disks but Zorin couldn't install because the old fedora installation lvms were still present. (Lots of lvdisplay, pvscan,and stuff I don't really understand)
If I do go the full wipe route, how do I make sure that the LVM won't f*** anything up?

Back to the OP, grub isn't booting directly into zorin. It seems that grub isnt actually using the grub.cfg. I say this because even a small change, like the amount of seconds timeout, is not changing when I change them and run update-grub. Also, @Swarfendor437 said the green progres bar on top should be there for ten seconds, which is what the /etc/default/grub shows, but on boot the bar goes for a lot more than 10 seconds. I haven't waited till the end but I think it's 30.
User avatar
kcaps
 
Posts: 14
Joined: Thu Jan 09, 2020 8:05 am

Re: Boot directly into Zorin

Postby kcaps » Tue Jan 14, 2020 10:12 pm

Looking at /boot/grub/grub.cfg, I see:

Code: Select all
set theme=($root)/usr/share/grub/themes/zorin/theme.txt
export theme
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=hidden
    set timeout=3
...


Looks like this might be related?
https://ubuntuforums.org/showthread.php?t=2412153
Last edited by kcaps on Tue Jan 14, 2020 10:31 pm, edited 1 time in total.
User avatar
kcaps
 
Posts: 14
Joined: Thu Jan 09, 2020 8:05 am
Next

Return to Help and Support

Who is online

Users browsing this forum: Google [Bot] and 11 guests