Trying to get 2 different LAN printers working withZorin

Trying to get 2 different LAN printers working withZorin

Postby ozstar » Sat Jan 11, 2020 5:26 am

Hi,

I have 2 printers installed ColorQube-8570DN and Xerox-Phaser-6250DP

When I try to print a test page from the Settings Printers area I get..

For the 6250 Phaser the only print on the page.

ERROR:
TimeOut
OFFENDINGF COMMAND
timeout
STACK
--nostringval--
/HT
InitialExtGState


On the 8570 I cannot even get any response from the Test Page Button.

I see this in logs but not sure what it means.

#5 561605b0e480 i /usr/share/gnome-shell/extensions/zorin ... orinos.com/extension.js:203 (7f19222eedc0 @ 28)


I guess I need the drivers for Linux for these machines. I see on the Xerox a driver but it says Fedora and Red Hat.

I have the LAN IP #s for both but not sure where to put them.

In debugging I get this response frpl terminal.

Code: Select all
su -c 'journalctl -u cups.service --since="None" --until="2020-01-11 15:24:52"' > troubleshoot-logs.txt
Failed to parse timestamp: None


This is the result.. Not sure if it has the answer here..

Code: Select all
Page 1 (<troubleshoot.SchedulerNotRunning.SchedulerNotRunning object at 0x7ffb60bb6390>):
{'cups_connection_failure': False}
Page 2 (<troubleshoot.ChoosePrinter.ChoosePrinter object at 0x7ffb60bb6128>):
{'cups_dest': <cups.Dest Xerox-Phaser-6250DP (default)>,
'cups_instance': None,
'cups_queue': 'Xerox-Phaser-6250DP',
'cups_queue_listed': True}
Page 3 (<troubleshoot.CheckPrinterSanity.CheckPrinterSanity object at 0x7ffb60bb69e8>):
{'cups_device_uri_scheme': 'dnssd',
'cups_printer_dict': {'device-uri': 'dnssd://Phaser%206250DP%20(8a%3A38%3Ab8)._pdl-datastream._tcp.local/',
                       'printer-info': 'Xerox Phaser 6250DP',
                       'printer-is-shared': True,
                       'printer-location': '',
                       'printer-make-and-model': 'Xerox Phaser 6250DP '
                                                 'Foomatic/Postscript',
                       'printer-state': 4,
                       'printer-state-message': 'Connected to printer.',
                       'printer-state-reasons': ['none'],
                       'printer-type': 8564756,
                       'printer-uri-supported': 'ipp://localhost/printers/Xerox-Phaser-6250DP'},
'cups_printer_remote': False,
'is_cups_class': False,

There are many more lines if you want to see..

How do I get them working please?


EDIT:

I have chosen the printer in Network printers and the manufacturer as well as the IP # however it does show the model but a search doesn't come up with anything.

In the Phaser 6250 Printer Properties OI see the ink levels etc but every test page shows that ERROR mentioned above.
HP-Compaq 6000 Tower - 4 K Ram Graphics: Intel® Q45/Q43
Intel® Core™2 Quad CPU Q9650 @ 3.00GHz × 4 Linux Zorin 15 64bit
Dual Boot with Win 10x64 1909
User avatar
ozstar
 
Posts: 117
Joined: Fri Dec 06, 2019 5:46 am
Location: Sydney Oz

Re: Trying to get 2 different LAN printers working withZorin

Postby Swarfendor437 » Sat Jan 11, 2020 2:50 pm

https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11909
Joined: Wed Sep 18, 2013 5:51 pm

Re: Trying to get 2 different LAN printers working withZorin

Postby ozstar » Sun Jan 12, 2020 1:04 am

Thanks.
Took a look but not sure if it also for my ColorCube 8570.

It and the Phaser 6250 are a little tricky in the driver dept. even for Windows 10. I will check with Xerox I guess.

Got this link too which I will look at.

https://veronneau.org/installing-xerox- ... linux.html
HP-Compaq 6000 Tower - 4 K Ram Graphics: Intel® Q45/Q43
Intel® Core™2 Quad CPU Q9650 @ 3.00GHz × 4 Linux Zorin 15 64bit
Dual Boot with Win 10x64 1909
User avatar
ozstar
 
Posts: 117
Joined: Fri Dec 06, 2019 5:46 am
Location: Sydney Oz

Re: Trying to get 2 different LAN printers working withZorin

Postby Swarfendor437 » Sun Jan 12, 2020 2:58 pm

ozstar wrote:Thanks.
Took a look but not sure if it also for my ColorCube 8570.

It and the Phaser 6250 are a little tricky in the driver dept. even for Windows 10. I will check with Xerox I guess.

Got this link too which I will look at.

https://veronneau.org/installing-xerox- ... linux.html


That looks like the answer to me just skim reading - well found! ;) :D
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11909
Joined: Wed Sep 18, 2013 5:51 pm

Return to Help and Support

Who is online

Users browsing this forum: Google [Bot] and 10 guests