Keyboard stopped working in terminal

Keyboard stopped working in terminal

Postby ozstar » Sun Jan 12, 2020 7:22 am

Hi,

Just as was about to enter a new password in the terminal it decided not to work.

No matter what I do the cursor just blinks and no keys do anything. I even tried the screen KB but that too was no good.

Saw where many have had sim problem but I am not sure how it was fixed.

I do not want to close and leave the terminal unless I have too as I am setting up mySQL and just about to enter the password, so not sure what impact that will have on the install.

I can open another terminal window and the KB works there.

What shall I do?

Thanks

oz
HP-Compaq 6000 Tower - 4 K Ram Graphics: Intel® Q45/Q43
Intel® Core™2 Quad CPU Q9650 @ 3.00GHz × 4 Linux Zorin 15 64bit
Dual Boot with Win 10x64 1909
User avatar
ozstar
 
Posts: 117
Joined: Fri Dec 06, 2019 5:46 am
Location: Sydney Oz

Re: Keyboard stopped working in terminal

Postby Swarfendor437 » Sun Jan 12, 2020 3:06 pm

https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11869
Joined: Wed Sep 18, 2013 5:51 pm

Re: Keyboard stopped working in terminal

Postby ozstar » Sun Jan 12, 2020 10:34 pm

Thanks. Yes saw that and tried all the options however it did not help.

I enter this command sudo mysql_secure_installation and I was able to use my root password to get the Y / N options.

No matter what option I choose I was not able yo get any response at all out of the USB Keyboard.

I opened another terminal window and the KB worked fine except when I did the same sudo mysql_secure_installation commnad the same thing happened.

It seems to me to be something awry in the code at that time.

It does seem to be a bug so I will report it to Ubuntu.

In the meantime seems like I cannot install mySQL (Maria) properly.

What say you?
HP-Compaq 6000 Tower - 4 K Ram Graphics: Intel® Q45/Q43
Intel® Core™2 Quad CPU Q9650 @ 3.00GHz × 4 Linux Zorin 15 64bit
Dual Boot with Win 10x64 1909
User avatar
ozstar
 
Posts: 117
Joined: Fri Dec 06, 2019 5:46 am
Location: Sydney Oz

Re: Keyboard stopped working in terminal

Postby Swarfendor437 » Mon Jan 13, 2020 12:08 am

https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11869
Joined: Wed Sep 18, 2013 5:51 pm

Re: Keyboard stopped working in terminal

Postby ozstar » Mon Jan 13, 2020 12:14 am

Sorry not sure what you mean.
HP-Compaq 6000 Tower - 4 K Ram Graphics: Intel® Q45/Q43
Intel® Core™2 Quad CPU Q9650 @ 3.00GHz × 4 Linux Zorin 15 64bit
Dual Boot with Win 10x64 1909
User avatar
ozstar
 
Posts: 117
Joined: Fri Dec 06, 2019 5:46 am
Location: Sydney Oz

Re: Keyboard stopped working in terminal

Postby Swarfendor437 » Mon Jan 13, 2020 12:28 am

Just wondered if there was any element of your setup that might include dependencies in that LAMP tutorial which inferred to the MariaDB in the tutorial. ;) :D
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11869
Joined: Wed Sep 18, 2013 5:51 pm

Re: Keyboard stopped working in terminal

Postby ozstar » Mon Jan 13, 2020 12:46 am

Wouldn't it say there is an error? Although I'm not saying there isn't one.

In my experience with Linux there are so many variations in tutorials and forum answers that one at times has no idea where they are because nothing seems to work doing what they say.

Here we go again, I search to see how to install php and mySQL after I had the webserver running okay and I could not come up with one clear concise tutor. I naturally went with what was suggested, so can only assume that there is a chance it may work.

I see this..
david@david-HP-Compaq-6000-Pro-MT-PC:~$ mysql --version
mysql Ver 14.14 Distrib 5.7.28, for Linux (x86_64) using EditLine wrapper


and this

david@david-HP-Compaq-6000-Pro-MT-PC:~$ sudo mysql –V
[sudo] password for david:
ERROR 1049 (42000): Unknown database '–V'


and in mysql

mysql> \s
--------------
mysql Ver 14.14 Distrib 5.7.28, for Linux (x86_64) using EditLine wrapper

Connection id: 8
Current database:
Current user: root@localhost
SSL: Not in use
Current pager: stdout
Using outfile: ''
Using delimiter: ;
Server version: 5.7.28-0ubuntu0.18.04.4 (Ubuntu)
Protocol version: 10
Connection: Localhost via UNIX socket
Server characterset: latin1
Db characterset: latin1
Client characterset: utf8
Conn. characterset: utf8
UNIX socket: /var/run/mysqld/mysqld.sock
Uptime: 3 hours 22 min 30 sec

Threads: 1 Questions: 11 Slow queries: 0 Opens: 107 Flush tables: 1 Open tables: 100 Queries per second avg: 0.000

--------------

and this..

david@david-HP-Compaq-6000-Pro-MT-PC:~$ sudo mysqladmin -u root -p status
Enter password:
Uptime: 12424 Threads: 1 Questions: 13 Slow queries: 0 Opens: 107 Flush tables: 1 Open tables: 100 Queries per second avg: 0.001



So does it look like it is okay, if not how do I check that what I installed was correct?

Thanks Swarfendor437./ - Yet another bombshell from me.- Sorry :-)
HP-Compaq 6000 Tower - 4 K Ram Graphics: Intel® Q45/Q43
Intel® Core™2 Quad CPU Q9650 @ 3.00GHz × 4 Linux Zorin 15 64bit
Dual Boot with Win 10x64 1909
User avatar
ozstar
 
Posts: 117
Joined: Fri Dec 06, 2019 5:46 am
Location: Sydney Oz

Re: Keyboard stopped working in terminal

Postby Swarfendor437 » Mon Jan 13, 2020 2:00 pm

:? As you can see you are much higher than me in your knowledge! I have also read about bugs in 18.04 so suspect this may be the real culprit.
Have you checked on the appropriate forums for your particular project? ;) :D
https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11869
Joined: Wed Sep 18, 2013 5:51 pm

Return to Help and Support

Who is online

Users browsing this forum: No registered users and 8 guests