Unable to update GNOME Application Platform

Unable to update GNOME Application Platform

Postby cb3 » Mon Jan 13, 2020 6:28 pm

Hi all, I'm running into an error where GNOME Software application is giving an error for updating GNOME Application Platform. It seems something is messed up and it may have been because I tried to add a repository at some point. Anyone know how I might be able to resolve this. I did see on google that running a flatpak update from terminal seems to work for a little while, but then the issue reappears again some time later. Here is a screenshot of the error I get.

gnomeapplicationplatform.png
User avatar
cb3
 
Posts: 2
Joined: Mon Jan 13, 2020 6:12 pm

Re: Unable to update GNOME Application Platform

Postby Swarfendor437 » Mon Jan 13, 2020 7:10 pm

https://vimeo.com/user15592214
https://www.deviantart.com/swarfendor437
https://trisquel.info/

Machine: ASUS X470-PRO, AMD Ryzen 7 1700X 8 Core, 16 Gb RAM, ZOTAC Geforce GT1030 (2 Gb)
User avatar
Swarfendor437
 
Posts: 11625
Joined: Wed Sep 18, 2013 5:51 pm

Re: Unable to update GNOME Application Platform

Postby cb3 » Mon Jan 13, 2020 7:26 pm

Thanks - I've tried something like this before but didn't seem to work, I'll give it a shot again per your link.
User avatar
cb3
 
Posts: 2
Joined: Mon Jan 13, 2020 6:12 pm

Re: Unable to update GNOME Application Platform

Postby sickice » Wed Feb 19, 2020 10:40 am

Hello

try this it have worked for me.

first do the update


$ flatpak update
Looking for updates…


ID Arch Branch Op Remote Download
1. [✓] org.freedesktop.Platform.Locale x86_64 18.08 u flathub 1.0 kB / 316.0 MB
3. [✓] org.freedesktop.Sdk.Locale x86_64 18.08 u flathub 1.0 kB / 319.4 MB
4. [✓] org.gnome.Platform.Locale x86_64 3.28 u flathub 1.0 kB / 188.9 MB
5. [✓] org.gnome.Platform.Locale x86_64 3.30 u flathub 1.0 kB / 320.2 MB
7. [✓] org.gnome.Platform x86_64 3.34 u flathub 1.0 kB / 318.4 MB
9. [✓] org.gnome.Sdk x86_64 3.34 u flathub 1.0 kB / 658.5 MB
10. [✓] org.gnome.Sdk.Locale x86_64 3.34 u flathub 1.0 kB / 326.3 MB
11. [✗] org.freedesktop.Platform.openh264 x86_64 19.08 i flathub 593.6 kB / 593.4 kB

Warning: org.freedesktop.Platform.openh264 not installed
Changes complete.


ID Arch Branch Remote Download
1. [✓] org.gnome.Sdk.Locale x86_64 3.32 flathub 17.4 kB / 323.2 MB
2. [✓] org.freedesktop.Platform.html5-codecs x86_64 18.08 flathub 2.9 MB / 3.3 MB
3. [✓] org.freedesktop.Platform.VAAPI.Intel x86_64 18.08 flathub 1.8 MB / 1.8 MB

Installation complete.

When this you see everything is fine now.
If not and you get a warning like this:


$ flatpak update
This gave: Warning: Failed to install org.freedesktop.Platform.openh264/x86_64/19.08: Error deploying: While trying to apply extra data: runtime/org.freedesktop.Platform/x86_64/19.08 not installed

Then preform a repair

$flatpak repair
$flatpak install flathub org.freedesktop.Platform/x86_64/19.08
$flatpak update

If it worked then you are good if not then do this:

$flatpak install org.freedesktop.Platform/x86_64/19.08
$flatpak uninstall --unused
$flatpak update

Now it should be fine but to get sure do the install again then you should get a answere that everything is up to date.

$flatpak install org.freedesktop.Platform/x86_64/19.08

Or do the update command and when you see " Nothing to do " then every thing is working now.


$flatpak update
Nothing to do.

Best reboot you Linux and then look if the Gnome massage is gone, and do the Update command to get sure you are fine now "sudo apt-get update && sudo apt-get upgrade"
When it have worked not forget to mark it as [SOLVED]

Have fun
User avatar
sickice
 
Posts: 10
Joined: Tue Jul 02, 2019 6:15 pm

Return to Help and Support

Who is online

Users browsing this forum: Google [Bot] and 9 guests